Ask Your Question
0

defense travel

asked 2016-03-12 17:30:47 -0600

ibowhunt gravatar image

updated 2016-03-27 08:26:38 -0600

I am a new user to Fedora 23 and linux in general. My issue is that the Defense Travel System uses Java and does not support OpenJDK. I have downloaded the Linux package and installed the latest version of Java from their website however, I have no clue how to make it the default and activate it as opposed to using OpenJDK in Firefox. Any clue on how to make this happen or do I just fall back to Microsoft to get this done?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-03-13 05:46:47 -0600

updated 2016-03-20 17:17:25 -0600

There is a good walk through for this here.

edit flag offensive delete link more

Comments

I was able to disable Open JDK and get java running to where DBsign will start but now gives me the error - "Could not write configuration data: /home/user/.DBsign/UWC/DBsign/cfg (No such file or directory)"

ibowhunt gravatar imageibowhunt ( 2016-03-20 13:44:13 -0600 )edit

the error code is 138. I am not sure but think it may be something to do with read and write errors in the folder. I changed the parent folder permissions but that didn't help. The new error message is Could not write configuration data /home/user/.DBsign/UWC/DBsign.cfg (Permission denied)

ibowhunt gravatar imageibowhunt ( 2016-03-20 14:28:16 -0600 )edit

Are you logged in as User user? If so, you also have to chown -R user /home/user/.DBsign/UWC.

thomaswood gravatar imagethomaswood ( 2016-03-21 03:31:21 -0600 )edit
1

answered 2016-04-25 17:32:55 -0600

colebarnes gravatar image

The underlying issue is likely that SELinux is blocking this operation.

By default, Mozilla plugins are sandboxed by SELinux and not allowed to write to the file system. The DBsign software, that runs within the Java plugin, needs to create that directory and write its configuration file. SELinux is blocking this from happening.

In order to keep this from happening, you must tell SELinux not to confine mozilla plugins like this:

sudo setsebool -P unconfined_mozilla_plugin_transition 0

If you want to re-enable this setting, do this:

sudo setsebool -P unconfined_mozilla_plugin_transition 1
edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-03-12 17:30:47 -0600

Seen: 334 times

Last updated: Mar 20 '16