Ask Your Question
2

sound stopped working on F23

asked 2016-03-11 11:33:15 -0500

ed.von.schleck gravatar image

I'm on a fully upgraded (Kernel 4.4.3) Fedora 23 on a 2015 Dell XPS 13, latest BIOS firmware. A week ago or so, sound suddenly stopped working. I don't know what upgrade broke it, as booting with the previous kernel didn't fix it.

It isn't the speakers – headphones won't do as well. It's not even the sound chip (broadwell-rt286) – an external audio device (focusrite scarlett 2i2) doesn't work either. All sound cards appear properly in the audio settings application (or pavucontrol, for that matter), and they are indicating that all is doing well and sound is playing while it is clearly not playing at all.

I've re-installed Fedora, but to no avail. dmesg and journalctl don't give a hint at what might be broken. I've run out of things to try.

I'd be grateful for any hints, and will provide information about my system if required. I'll try other distributions in the coming days and update my question if I find something useful, but I'd hate to leave Fedora for this stupid bug after using it since FC2.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
3

answered 2016-03-11 18:08:33 -0500

cprofitt gravatar image

updated 2016-03-17 10:37:20 -0500

I am not sure if your problem is the same as mine, but here is what I have found so far.

The sound card makes a popping noise on boot because it is using the I2S mode under the newer kernel. In my case it then defaults to using the HDMI output for the sound instead of the broadwell-rt286. Currently if I open settings and select the sound card I get sound. It does not stick after a reboot though so I am researching a way to make it select the correct sound card at boot.

Also, when I plug in my headphones I get what sounds like a car horn sound in them. When I then remove them the computer speakers sound like rushing traffice (no horn).

Edit I found the following advice:

  • Open a new terminal window and start
  • alsamixer. Press F6 and select the broadwell-rt286 device
  • Press F3 (playback) and set the following settings:

    Master: 100 (all the way up, arrow keys)
    Headphones: 00 (press m to flip between mute and on, 00 means on)
    Speaker: 00
    Front DAC: 00
    Front REC: mm
    ADC 0 Mux: Dmic (arrow keys)
    ADC 1 Mux: Dmic
    AMIC: 100
    DAC0: 100
    HPO L: 00
    HPO Mux: front
    HPO R: 00
    Media0: 100
    Media1: 100
    RECMIX Beep: 00
    RECMIX line1: 00
    RECMIX mic1: 00
    SPK Mux: front
    SPO: 00
    

This resolved all the issues for me.

Source: http://forthescience.org/blog/tag/xps...

edit flag offensive delete link more

Comments

That is a great pointer, but I'm afraid it's not the solution for my problem. My soundcard is correctly selected at startup, and switching to HDMI and back doesn't help. Thanks for the quick response, though!

ed.von.schleck gravatar imageed.von.schleck ( 2016-03-12 02:06:04 -0500 )edit

This amazingly worked for me. I've been disappointed so far in Fedora's support of audio on the XPS 2015 and had been sticking with F22 since F23 had this audio problem out of the box. Some recent yum update broke the audio on F22 though as well but this fix did the trick.

mcaudill gravatar imagemcaudill ( 2016-04-08 19:15:42 -0500 )edit
0

answered 2016-12-15 20:10:40 -0500

It seems strange that the audio worked originally, then broke, and now continues to fail after a re-install.

If the audio did not come back after a re-install, I might suspect that this could be a hardware / driver issue.

I am having a fair share of issues with Fedora 23 audio myself. I use two different bluetooth audio speakers (one can speaker and a pair of bluetooth headphones). I switch between the two depending on need. From time to time the audio drops off the system completely (this occurs about once a day now), including the audio volume slider in the UI which just disappears.

I've come to find that there are quite a few variables in troubleshooting sound issues in Fedora. I focused my troubleshooting on pulseaudio which I learned to be a kind of sound engine for Fedora.

My initial solution to bring the audio back up without restarting the machine was to run the following command: sudo killall pulseaudio

This killed pulseaudio and pulseaudio subsequently reloaded itself which brought my audio back online. Note that running this command would work the first time however not subsequent times if the audio failed again (at which point I would reboot to resolve). This method for restoring audio eventually started to fail at which point I decided to perform a clean on the memory cache by doing the following: sudo sh -c "sync; echo 3 > /proc/sys/vm/drop_caches"

After cleaning memory cache, I noticed I was no longer experiencing any issues. I think this have may cleared some "clutter" for pulseaudio. I do not necessarily consider this a solution until I get some good running time with the audio (just performed this recently).

If I continue to experience issues, I am going to realign my troubleshooting efforts and begin to look at alsactl which I believe interfaces directly with the sound card.

I hope this may help you.

edit flag offensive delete link more
0

answered 2016-08-23 18:13:46 -0500

ldeks gravatar image

cprofit's settings worked for me, but I had to open the Sound app and select broadwell-rt286 to get it to start working.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-03-11 11:33:15 -0500

Seen: 1,057 times

Last updated: Mar 17 '16