Ask Your Question
0

Tux Guitar no sound

asked 2011-11-18 03:25:58 -0500

Hi, I didn't have problems with tux guitar in F15, but now in F16 it doesn't reproduce sound.

I have the 1.2 version, It use like MIDI Sequencer: TuxGuitar Sequencer, like MIDI Port: Midi Through Port-0 [14:0].

If I run it from a terminal it doesn't throw any error or warning message.

I have the card HDA Nvidea and the chip Nvidea MCP79/7A HDMI. What could I do? What extra information do you need?

Regards.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-18 04:23:09 -0500

lzap gravatar image

First of all locate your sound.properties file:

# locate sound.properties
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/sound.properties

Edit it and set javax.sound.sampled properties to PulseAudio providers. They are there already in Fedora 15 and you only have to uncomment it (and comment out the originals).

javax.sound.sampled.Clip=org.classpath.icedtea.pulseaudio.PulseAudioMixerProvider
javax.sound.sampled.Port=org.classpath.icedtea.pulseaudio.PulseAudioMixerProvider
javax.sound.sampled.SourceDataLine=org.classpath.icedtea.pulseaudio.PulseAudioMixerProvider
javax.sound.sampled.TargetDataLine=org.classpath.icedtea.pulseaudio.PulseAudioMixerProvider

#javax.sound.sampled.Clip=com.sun.media.sound.DirectAudioDeviceProvider
#javax.sound.sampled.Port=com.sun.media.sound.PortMixerProvider
#javax.sound.sampled.SourceDataLine=com.sun.media.sound.DirectAudioDeviceProvider
#javax.sound.sampled.TargetDataLine=com.sun.media.sound.DirectAudioDeviceProvider

If it does not work put it back.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-18 03:25:58 -0500

Seen: 1,294 times

Last updated: Nov 18 '11