Ask Your Question
0

How-to enable systemd-modules-load.service on restart

asked 2016-03-07 08:17:44 -0500

foofig gravatar image

I know this isn't directly Fedora related, as I pulled down the VirtualBox packages from RPM Fusion (_the ones one Oracle's site didn't work with the Fedora 23's kernel._) Things work fine, but only after I run the following command:

sudo systemctl restart systemd-modules-load.service

I tried enabling the service, but get:

The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).

How can I go about reloading this service when I login? Or is it an issue where my modules aren't getting loaded in the proper order? Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-07 09:55:41 -0500

sergiomb gravatar image

updated 2016-03-07 20:12:15 -0500

When we install VirtualBox , the order of installing things is complicated , after install VB you need run akmods after , akmods install kmod , you need load the modules just after that VB is ready (as host) . Or simply after install VB , reboot the system.

systemctl is-enabled systemd-modules-load

static

reading man systemctl "static" Unit file is not enabled, and has no provisions for enabling in the "[Install]" section.

but runs at start up , well at least for me ... don't remember anyone complains about not running at start up.

BTW: I wrote a draft here: http://rpmfusion.org/Howto/VirtualBox , about how install VirtualBox with rpmfusion repos.

edit flag offensive delete link more
0

answered 2016-03-07 08:59:37 -0500

aeperezt gravatar image

By the error there looks like you are missing the Install section of the systemd init file, the install section define when the service will start, so you can edit the file and add it.

[Install]
WantedBy=default.target

Please look at https://access.redhat.com/documentati... to learn more about the systemd init files.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-03-07 08:17:44 -0500

Seen: 432 times

Last updated: Mar 07 '16