Ask Your Question
1

Activating "lcddefault" on Wayland possible?

asked 2016-03-04 07:06:05 -0500

Kid X gravatar image

Hi everyone,

I recently installed Fedora 23 and changed the default settings as outlined here: http://peter.kingofcoders.com/?p=177

It works when using the default Gnome desktop, but when switching to Wayland and inputting "xrdb -query" into terminal, the "Xft.lcdfilter: lcddefault" setting seems to be disabled / not working (it doesn't show up). I tried manually re-creating the hidden file in ./Xresources but get an error when trying to do so in Wayland.

Since Wayland looks to be becoming the default desktop in Fedora 24, I was wondering whether anyone has had this issue and possibly a fix/workaround?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-05 01:22:43 -0500

knesset gravatar image

Yep, you should do

sudo ln -s /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/
edit flag offensive delete link more

Comments

Thanks for this answer. Still does not show up in xrdb -query (which shows the X-server resource database), but it does enable subpixel rendering (with freetype-freeworld) under Wayland. This is best visible in Google Chrome. Font rendering in F24 improved tremendously, which makes the gain in most other applications only small.

JanvdK gravatar imageJanvdK ( 2016-07-30 00:44:23 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2016-03-04 07:06:05 -0500

Seen: 1,072 times

Last updated: Mar 04 '16