Ask Your Question

After Kernel 4.3.5-200.fc22 and Kernel 4.3.6-201.fc22x86_64 break Broadcom bcm4312

asked 2016-02-29 21:34:35 -0500

MarkL gravatar image

I upgraded DNF upgrade I am having the same problem that keep recurring. After installing both kernels 4.3.5-200 and 4.3.6-201 has broken Broadcom bcm4312 and reloading akmods does not fix the wireless networking.

Here is what I get

dnf update --best --allowerasing

i get the following result

Last metadata expiration check performed 0:55:25 ago on Mon Feb 29 20:24:46 2016. Dependencies resolved. Nothing to do. Complete!

akmods --force

I get the following result.

Checking kmods exist for 4.3.6-201.fc22.x86_64 [ OK ] #

modprobe wl

I get the following result

modprobe: FATAL: Module wl not found in directory /lib/modules/4.3.6-201.fc22.x86_64 #

I have check the directories of all kernels and the wl module is in the same place in all of them.

the wifi works in kernel 4.3.4-200.fc22.x86_64 but not in the last two kernel updates and the process I have used in the past to load the akmods does not work in these kernels. I feel there is a module conflict but cannot find it.

Has anyone found a workaround or know of a Broadcom driver that will work with the latest updates of Fedora 22 kernels please let me know. Does anyone have a akmods-wl that will work with these two kernel.

I would appreciate any help with this issue.

edit retag flag offensive close merge delete


How did ya install broadcom-wl? Guessing you used one of rpmfusion's repos. If so, you'll probably have to wait until the package in their repos gets bumped for the latest kernel. I would personally recommend, that until that time you uninstall broadcom-wl from those repos and install broadcom-wl using another method (if you want I can give you one in an answer, if I am right in saying you're using the rpmfusion repo).

Brenton Horne gravatar imageBrenton Horne ( 2016-02-29 23:05:00 -0500 )edit

and what is version of broadcom-wl ?

sergiomb gravatar imagesergiomb ( 2016-04-01 20:25:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-08-01 12:46:28 -0500

coolgamesnet gravatar image

updated 2016-08-01 13:03:31 -0500

It now fails on 4.6.4-301.fc24.i686+PAE

hybrid_wl_f23]# make clean KBUILD_NOPEDANTIC=1 make -C /lib/modules/uname -r/build M=pwd clean make[1]: * /lib/modules/4.6.4-301.fc24.i686+PAE/build: No such file or directory. Stop. Makefile:165: recipe for target 'clean' failed make: * [clean] Error 2

~]# ls -l /lib/modules/4.6.4-301.fc24.i686+PAE/build lrwxrwxrwx. 1 root root 40 Jul 12 08:23 /lib/modules/4.6.4-301.fc24.i686+PAE/build -> /usr/src/kernels/4.6.4-301.fc24.i686+PAE

System is HP 1125 Netbook with Broadcom bcm4312

It was working with Ubuntu 14.04 which has been replaced with Fedora

edit flag offensive delete link more

answered 2016-03-01 00:33:53 -0500

updated 2016-03-01 00:36:17 -0500

Not sure why I haven't heard from you in the comments, but anyway here is the method for installing broadcom-wl without using pre-built RPM binaries from rpmfusion or other sources. It can be helpful when available broadcom-wl RPMs have bugs (which I think is the case here) or have become outdated and do not work with your current kernel. It is explained in greater detail here (and yes I know this article is written for Fedora 23, but looking in their script I can't find any reason why it shouldn't work on Fedora 22 without modification). Simply run:

wget -v -O && sh ./;

unfortunately this does require an Internet connection (so use an Ethernet cable if you can). Alternatively, if you cannot get such an Internet connection via other means on your Fedora PC, you can download on a PC with an Internet connection and transfer this file (via a USB, removable drive, or w/e) to your Fedora PC and run (from the same directory in which you have the hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz archive):

mkdir hybrid_wl_f22
mv hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz hybrid_wl_f22
cd hybrid_wl_f22

# Extra the driver files.
tar zxvf hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz

# Compile driver.
make clean && make

# Install driver.
sudo make install

# Update available drivers.
sudo depmod -a

# Unload conflicting drivers.
sudo rmmod b43 ssb bcma

# Load the driver.
sudo modprobe wl

# Blacklist conflicting drivers.
printf 'blacklist b43\nblacklist ssb\nblacklist bcma\n' | sudo tee /etc/modprobe.d/wl.conf

# Load driver automatically at boot time.
echo 'wl' | sudo tee /etc/modules-load.d/wl.conf
edit flag offensive delete link more


I can confirm that this works on a late 2011 MacBook Pro with a BCM4331 chip in it with Fedora 24 running 5.4.7-300.fc24.x86_64 kernel. Thank you for posting this! I looked in many places and this was very simple to follow and to the point.

Acithium gravatar imageAcithium ( 2016-06-27 08:48:29 -0500 )edit

Question Tools



Asked: 2016-02-29 21:34:35 -0500

Seen: 510 times

Last updated: Aug 01 '16