Ask Your Question
0

No sound with kernel 4.4

asked 2016-02-28 14:38:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

After upgrading to kernel 4.4 (4.4.2-301.fc23.x86_64) I have no sound. I run fedora 23 on a Dell XPS 13 (model 9343, 2015 - bios A07). I did several cold reboots, as recommended in

https://wiki.archlinux.org/index.php/...

but still no sound.

cat /proc/asound/cards yields:

0 [HDMI ]: HDA-Intel - HDA Intel HDMI HDA Intel HDMI at 0xf741c000 irq 50

1 [PCH ]: HDA-Intel - HDA Intel PCH HDA Intel PCH at 0xf7418000 irq 49

alsa-info.sh --no-upload yields:

cat: /sys/module/snd_soc_sst_broadwell/parameters/*: No such file or directory

Your ALSA information is in /tmp/alsa-info.txt.j7ZgNgmtWy

This file is available at

https://dl.dropboxusercontent.com/u/2...

lspci -nn | grep -i audio yields

00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09)

play -l yields

* List of PLAYBACK Hardware Devices * card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: broadwellrt286 [broadwell-rt286], device 0: System Playback/Capture () [] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: broadwellrt286 [broadwell-rt286], device 1: Offload0 Playback () [] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: broadwellrt286 [broadwell-rt286], device 2: Offload1 Playback (*) [] Subdevices: 1/1 Subdevice #0: subdevice #0

Suggestions are welcome.

edit retag flag offensive close merge delete

Comments

Why are you using the arch wiki for debugging sound on Fedora? See https://fedoraproject.org/wiki/How_to... and https://ask.fedoraproject.org/en/ques...

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-29 06:19:16 -0500 )edit

Thank you. The reason I looked at the Arch wiki was because this problem seems to be related to kernel 4.4 and is also affecting users of other distributions. Anyway, that was just to say that I tried the cold reboots suggestions to no success. I had no audio problems with all previous Fedora kernels, but with kernel 4.4 I have no audio at all. I looked at the pages you suggested. The solution in the second page did not work for me. My sound card is Realtek ALC3263.

cribari gravatar imagecribari ( 2016-02-29 08:45:45 -0500 )edit

I understand, but the arch kernel != fedora kernel and the fedora kernel team is going to want the information per the fedora documentation. If it worked with previous Fedora kernels, I highly suggest you file a bug report as per the links I gave you.

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-29 11:03:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-03 17:37:06 -0500

Had the same issue and resolved it via configuring alsamixer.

  • Dell XPS13 9343 (2015 model)
  • BIOS A07
  • Kernel 4.4.6

https://wiki.archlinux.org/index.php/...

$ cat /etc/modprobe.d/alsa-base.conf 

options snd_hda_intel index=1,0


$ aplay -l

**** List of PLAYBACK Hardware Devices ****  
card 0: broadwellrt286 [broadwell-rt286], device 0: System Playback/Capture (*) []
...

Bug Report, comment 18 referenced this blog post which describes configuration specifics.

Now you will need to do 2 restarts, and one cold boot (shutdown the machine, and power it back on).

... Open a new terminal window and start alsamixer. Press F6 and select the broadwell-rt286 device. on the playback tab (F3), set the following settings:

    Master: 100 (all the way up, arrow keys)
    Headphones: 00 (press m to flip between mute and on, 00 means on)
    Speaker: 00
    Front DAC: 00
    Front REC: mm
    ADC 0 Mux: Dmic (arrow keys)
    ADC 1 Mux: Dmic
    AMIC: 100
    DAC0: 100
    HPO L: 00
    HPO Mux: front
    HPO R: 00
    Media0: 100
    Media1: 100
    RECMIX Beep: 00
    RECMIX line1: 00
    RECMIX mic1: 00
    SPK Mux: front
    SPO: 00

Switch to the record tab (F4), and set the following settings:

    Mic: 100
    ADC0: 100 and CAPTURE (use the space bar to set CAPTURE)
    AMIC: 100
edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-02-28 14:38:42 -0500

Seen: 1,817 times

Last updated: Feb 29 '16