Ask Your Question

How to arrange dual montiors vertically

asked 2016-02-28 08:24:50 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I just installed fedora 23. I have two monitors that are arranged vertically. Both are working fine, except that fedora thinks the second monitor is to the right of the primary monitor. I went to settings->arrange combined displays, but when I try to reorient them the screens will flash momentarily and then return to the same way they were. If I try it a few times in a row it will crash fedora and log me out. I am using a AMD graphics card, but I am not using the AMD proprietary drivers and I would prefer not to, but I will if that is the only way to fix this.

edit retag flag offensive close merge delete


The "solution" that I found to this is to not have the second monitor positioned directly above, but instead above and slightly off to the side. For some reason that works.

bstruck gravatar imagebstruck ( 2016-04-06 18:36:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-28 12:44:14 -0500

updated 2016-02-28 12:46:17 -0500

Two options -

Command line:

Should work with xrandr, use the --above or --below options.

Syntax depends on your monitors names

To see your monitors run

xrandr -q

Example of using xrandr with my monitors:

xrandr --auto --output DVI-I-1 --mode 1920x1200 --right-of DVI-I-2

places the second monitor to the right of the first. In your case you would want something like

xrandr --auto --output DVI-I-1 --mode 1920x1200 --above DVI-I-2

You can then either write an xorg.conf or run xrandr at login, your choice

See : and

Graphical tools (gnome wayland):

In "Settings" there is a "Displays" tool -> Click the "Arrange Combined Displays" button and drag the screen to the location you want.

In the pictures below I have dragged the screen from side - by - side to above and below.

All Settings

image description

Other graphical tools exist for other DE if you are not using gnome-wayland

edit flag offensive delete link more


Thank you for your help, but this doesn't solve my problem. If I try either of the above solutions the screen flashes and says "gnome shell has crashed" if it try it again it will crash everything and require me to logout.

bstruck gravatar imagebstruck ( 2016-02-28 18:33:34 -0500 )edit

Gnome shell crashing when you set your monitors is a bug. You should file a bug report and you could try the ati driver.

bodhi.zazen gravatar imagebodhi.zazen ( 2016-02-28 23:23:42 -0500 )edit

Question Tools


Asked: 2016-02-28 08:24:50 -0500

Seen: 564 times

Last updated: Feb 28 '16