Ask Your Question
0

Why can't I start php-fpm?

asked 2016-02-27 08:38:48 -0500

Roman gravatar image

updated 2016-02-27 11:00:38 -0500

fedora 23, nginx 1.8.1
error in /var/log/php-fpm/error.log looks like:
WARNING: [pool www] ACL set, listen.group = 'www-data' is ignored
ERROR: unable to bind listening socket for address '/run/php-fpm/www.sock': Permission denied (13)
/run/php-fpm directory is 775 nginx nginx
from www.conf : listen.acl_users = apache,nginx
I also did: chcon -Rv --type=httpd_user_content_rw_t /run/php-fpm
so ls -Z system_u:object_r:httpd_user_rw_content_t:s0 php-fpm
I can't attach configs bc of karma. Is there any possibilities to do this?

edit retag flag offensive close merge delete

Comments

You can use pastebin for bigger code blocks or configurations. Might be best to have a look in there first.

thomaswood gravatar imagethomaswood ( 2016-02-27 12:44:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-05 11:20:22 -0500

remi gravatar image

Seems you have badly altered the default pool configuration. www-data doesn't exist on Fedora (this is a debian thing).

More: default provided configuration use:

 listen.acl_users = apache,nginx

Which is enough to allow access, no need to change the listen.owner or listen.group.

Notice: the provided configuration is designed to work "out-of-the-box", no change required, just have to start the nginx and php-fpm services.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-02-27 08:38:14 -0500

Seen: 1,650 times

Last updated: Mar 05 '16