Ask Your Question
0

My plymouth remains using too much loadtime...

asked 2016-02-23 12:47:51 -0500

linux23 gravatar image

I´m trying to reduce my TOO LONG boottime... I went from 1min 16sec. down to 1min 1sec. by disabling a lot of services which I don´t use.

I also disabled: plymouth.quit.wait.service

But then when I write: systemd-analyze blame, it shows plymouth.quit.wait.service(even after I disabled it...)

When I write: systemctl status plymouth.quit.wait.service, then it says: No such file or directory. Inactive(dead)

That makes no sense to me!

Isnt it possible to disable plymouth service ?

Thank in advanced

     35.803s plymouth-quit-wait.service
     10.716s firewalld.service
      8.297s dev-mapper-fedora\x2droot.device
      7.880s systemd-udev-settle.service
      5.767s systemd-journal-flush.service
      5.319s accounts-daemon.service
      4.633s libvirtd.service
      3.533s abrtd.service
      2.873s lvm2-monitor.service
      2.573s ModemManager.service
      2.232s gssproxy.service
      2.212s systemd-fsck-root.service
      2.169s polkit.service
      2.047s proc-fs-nfsd.mount
      1.927s systemd-fsck@dev-disk-by\x2duuid-cf634048\x2da20a\x2d47bb\x2dba
      1.903s chronyd.service
      1.863s packagekit.service
      1.821s systemd-logind.service
      1.799s livesys.service
      1.799s dnf-makecache.service
      1.793s netcf-transaction.service
      1.793s mcelog.service
      1.764s fedora-readonly.service
edit retag flag offensive close merge delete

Comments

Disable ModemManager if you are not using a modem.

Why is your firewalld taking so long?

You can also try minimizing the time systemd-journal takes. See here for problem, and here for solution

florian gravatar imageflorian ( 2016-02-23 13:30:03 -0500 )edit

Yes, I use a modem.

I also wonder why my firewalld is taking so long...but how to find out if I use ipt ? Because otherwise I would disable my firewallld...

linux23 gravatar imagelinux23 ( 2016-02-23 14:04:21 -0500 )edit

I don't know how to find out why your firewall is taking so long but I do know that it is not worth disabling it to save 10s during your boot. How often do you reboot? Once a day? So what do the 10 secs matter?

florian gravatar imageflorian ( 2016-02-23 15:31:03 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-02-23 14:18:46 -0500

sideburns gravatar image

Welcome to ask.fedora! There are, actually, two ways to keep a service from running at boot. Disabling it, as you did, only stops it from starting on its own; any other service that needs it (or, at least, thinks it needs it) can still start it, and that's probably what's happening here. If you want to make it stay dead until you decide otherwise, run this as root: systemctl mask plymouth.quit.wait.service and it won't be possible to start it via systemctl until you unmask it.

You might also want to run systemd-analyze critical-chain (You don't need root for this.) and see which services depend on which, and what other bottlenecks you have. Good luck, and let us know what happens.

edit flag offensive delete link more
0

answered 2016-02-23 15:03:22 -0500

linux23 gravatar image

After I did mask the plymouth, it still says that it takes 34 sec. to load...

After I used this code: mv /var/log/journal /var/log/journal.org I gained about 3 sec...

After I used critcal-chain it says:

graphical.target @49.593s └─multi-user.target @49.593s └─libvirtd.service @25.201s +5.704s └─network.target @25.187s └─wpa_supplicant.service @27.084s +422ms └─dbus.service @12.323s └─basic.target @12.315s └─sockets.target @12.315s └─iscsiuio.socket @12.315s └─sysinit.target @12.290s └─systemd-update-utmp.service @12.173s +115ms └─auditd.service @12.105s +66ms └─systemd-tmpfiles-setup.service @11.693s +339ms └─fedora-import-state.service @11.372s +316ms └─local-fs.target @11.294s └─run-user-42.mount @21.890s └─local-fs-pre.target @4.658s └─systemd-tmpfiles-setup-dev.service @4.065s +591ms └─kmod-static-nodes.service @3.163s +162ms └─system.slice └─-.slice

edit flag offensive delete link more

Comments

So what you're saying is, it now takes only 44.7% as much time as it did before, but it's not good enough. Sorry, but nothing else jumps out at me as a possibility. Maybe somebody else has an idea.

sideburns gravatar imagesideburns ( 2016-02-23 15:17:11 -0500 )edit

Plymouth was just confusing me, cause it didn´t seem to get masked...

Well, have a nice day! :-)

linux23 gravatar imagelinux23 ( 2016-02-23 15:44:34 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-02-23 12:47:51 -0500

Seen: 722 times

Last updated: Feb 23 '16