Ask Your Question
0

error while using make in libgraph1.0.2

asked 2016-02-21 06:26:38 -0500

hello guys , steps i followed installed all prerequisite packages

SDL_image SDL_image-devel guile guile-devel libart_lgpl libart_lgpl-devel audiofile audiofile-devel directfb directfb-devel freetype freetype-devel after that -

  1. Install the libgraph tar.gz file .
  2. installed dependencies.

    dnf install SDL_image SDL_image-devel.i686 guile.i686 guile-devel.i686

  3. extracted the downloaded tar and cd to it.

  4. performed these - (i). ./configure worked fine !

than finally when i did (ii) make

i got the error -

guile-libgraph.c:25:22: fatal error: libguile.h: No such file or directory compilation terminated. Makefile:460: recipe for target 'guile-libgraph.lo' failed make[2]: * [guile-libgraph.lo] Error 1 make[2]: Leaving directory '/root/Downloads/libgraph-1.0.2' Makefile:552: recipe for target 'all-recursive' failed make[1]: [all-recursive] Error 1 make[1]: Leaving directory '/root/Downloads/libgraph-1.0.2' Makefile:268: recipe for target 'all' failed make: ** [all] Error 2

please guide me

thanx in advance

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-21 12:53:50 -0500

[root@localhost libgraph-1.0.2]# CFLAGS=-l/usr/include/guile/2.0 ./configure checking build system type... x86_64-unknown-linux-gnu

checking host system type... x86_64-unknown-linux-gnu checking target system type... x86_64-unknown-linux-gnu checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking for gawk... gawk checking whether make sets $(MAKE)... yes checking whether to enable maintainer-specific portions of Makefiles... no checking for gcc... gcc checking for C compiler default output file name... configure: error: C compiler cannot create executables See `config.log' for more details.

edit flag offensive delete link more

Comments

sorry it should be CPPFLAGS not CFLAGS

fcomida gravatar imagefcomida ( 2016-02-21 17:36:40 -0500 )edit
0

answered 2016-02-21 11:22:45 -0500

fcomida gravatar image

updated 2016-02-21 17:37:21 -0500

It seems a bug in the building system. Run configure like this: ' CPPFLAGS=-I/usr/include/guile/2.0 ./configure' plus your configure options if any

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-02-21 06:21:24 -0500

Seen: 1,027 times

Last updated: Feb 21 '16