Ask Your Question

How do I change my monitor's resolution?

asked 2012-01-25 14:08:11 -0500

David_LeBlanc gravatar image

updated 2014-09-28 08:45:16 -0500

mether gravatar image

I have problems to change resolution. I tryed via editing the file /etc/default/grub and adding this line GRUB_GFXMODE="1280x1024x32" But it doesn't change.The KrandTry crashes after it stars to load, i didn't found the Xorg since my fedora is Verne, and some of the main solutions i found are quite old. Note: My monitor supports that resolution.

xrandr output is:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096 VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.0* 800x600 60.3 56.2
848x480 60.0
640x480 59.9

edit retag flag offensive close merge delete


What graphics card do you have ?

bodhi.zazen gravatar imagebodhi.zazen ( 2012-01-25 15:43:48 -0500 )edit

What is the output of xrandr?

skytux gravatar imageskytux ( 2012-01-26 06:11:41 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2012-01-26 11:13:52 -0500

ZenDark gravatar image

updated 2012-02-01 01:34:06 -0500

Create a file in /etc/X11/xorg.conf.d/


Section "Monitor"
  Identifier  "VGA1"
  Option      "PreferredMode" "1280x1024"

Restart your X system.

If it doesn't work try creating the next two files in the same path, and restarting again:


Section "Device"
    Identifier      "Intel Integrated"
    Driver          "intel"


Section "Screen"
    Identifier      "Default Screen"
    DefaultDepth  24
    SubSection "Display"
            Depth          24
            Modes         "1280x1024"  "1024x768"   "640x480"

Undetected resolution

If your monitor supports a resolution, but it's not published correctly, you can add it manually.

Look at the following link (section Adding undetected resolution)

Once you get it working make the changes persistent in a file inside /etc/X11/xorg.conf.d/

Persistent new modeline

After you added the new resolution for your monitor, you must save it. Execute:

cvt 1280 1024

You will get something as:

1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz

Modeline "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

The interesting bit is the modeline. Copy it and paste in a file: /etc/X11/xorg.conf.d/40-monitor.conf

Section "Monitor"
  Identifier  "VGA1"
  Modeline    "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
  Option      "PreferredMode" "1280x1024_60.00"

Restart X11 and there you go...

If the above doesn't make persistent your new configuration try adding the xrandr magic in a file read by xorg, by example gdm or kdm configuration:


edit /etc/gdm/Init/default

add the xrandr commands after



xrandr --newmode ...
xrandr --output YOURMONITOR --mode NEWMODE


You can add the xrandr lines in /etc/kde/kdm/Xsetup or in /etc/kde/kdm/Xsession but with full path:

/usr/bin/xrandr --newmode ...
/usr/bin/xrandr --addmode YOURMONITOR YOURNEWMODE
/usr/bin/xrandr --output YOURMONITOR --mode NEWMODE

If someone knows why saving the modeline in the xorg config doesn't get it applied, please let me know, I'm pretty curious (and the xorg webpage seems down at the moment)...

edit flag offensive delete link more

answered 2015-07-24 02:36:18 -0500

I have a MS Surface Pro 3 and a Samsung U28D UHD monitor. The intel chipset won't push the 60Hz 3840x2160 to this single panel monitor, so you have to go with ~30Hz, which means you have to add a new mode as above. Turns out it needs to be around 28Hz. To get this to work by default I added a /etc/X11/xorg.conf.d/10-monitor.conf which just contains the monitor bit:

Section "Monitor"
Identifier "DP2"
Modeline "3840x2160_28.00"  314.75  3840 4072 4480 5120  2160 2163 2168 2197 -hsync +vsync
Option "PreferredMode" "3840x2160_28.00"

Then I edited ~/.config/monitors.xml and changed the DP2 SAM entry to have a rate of 28. Heres the section:

<output name="DP2">

Ah, this is for the surface pro 3 dock display port, for the internal display port change DP2 to DP1.

Hope that helps.

edit flag offensive delete link more


this has been working brilliantly until the last dnf upgrade on fedora 25! now I'm having to add the modeline via xrandr again - sigh

pmcneil gravatar imagepmcneil ( 2017-01-18 15:40:41 -0500 )edit

It's no way working on my fedora

VishalKumarSahu gravatar imageVishalKumarSahu ( 2017-03-13 12:52:25 -0500 )edit

Question Tools

1 follower


Asked: 2012-01-25 14:08:11 -0500

Seen: 104,149 times

Last updated: Feb 02 '12