Ask Your Question
1

How to provide unrecognised monitor parameters (so that I will be able to change screen resolution)? [closed]

asked 2016-02-15 14:36:57 -0500

MateuszK gravatar image

updated 2016-02-16 12:44:12 -0500

I have LG 22M35A LED monitor. It is connected through VGA-DVI adapter.

My OS (Chapeau 23 based on Fedora 23) allows me to set only 1024x768 screen resolution. Since that I would like to set manually monitor parameters ie VertRefresh and HorizSync which I found in monitor specifications.

Since I can't find any graphical tool to set monitor parameters and I had no /etc/X11/xorg.conf file, I installed nvidia proprietary driver and allowed nvidia-settings to generate xorg.conf file.

In generated /etc/X11/xorg.conf file, I changed only VertRefresh and HorizSync. After saving and restart... my system crashed.

My questions are:

  • what is the reason of not recognising monitor (is it connection through DVI-VGA adapter)?
  • is there any GUI configuration tool which allows me to provide monitor parameters according to its specification (and test settings)?
  • if no GUI tool exists, what is the safest way of configuring monitor options? I know that I can set screen resolution through xrandr, but I guess it is not the case since it is not applying (?) VertRefresh and HorizSync properly

EDIT

So, I removed all partitions and re-installed my Chapeau 23.

I updated my system (sudo dnf update) and check if I am able to change resolution.

After typing: xrandr I get:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 16384 x 16384

DVI-I-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

1024x768 60.00*

800x600 60.32 56.25

848x480 60.00

640x480 59.94

HDMI-1 disconnected (normal left inverted right x axis y axis)

DP-1 disconnected (normal left inverted right x axis y axis)

After typing: lspci | grep VGA I get:

01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 645 OEM] (rev a1)

So both, graphics card and monitor support higher resolutions, but I am unable to change it (screenshot).

According to my monitor specifications:

Sync Input: Horizontal Frequency: 30 kHz to 83 kHz (Automatic)

Vertical Frequency: 56Hz to 75Hz (D-SUB)

Resolution: Max D-SUB(Analog): 1920 x 1080 @60Hz

Recommend: VESA 1920 x 1080 @60Hz

I confirm there's no /etc/X11/xorg.conf file.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2016-02-20 07:14:43.121144

Comments

Execute the command xrandr and post the results

paulojmlopes gravatar imagepaulojmlopes ( 2016-02-15 14:59:34 -0500 )edit

@paulojmlopes I edited my question to provide xrandr results.

MateuszK gravatar imageMateuszK ( 2016-02-16 12:30:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-18 10:43:30 -0500

MateuszK gravatar image

updated 2016-02-18 12:44:54 -0500

I feel this is a workaround only, but I'm unable to find anything better.

Since I need to add 1920 x 1080 x 60 Hz, I'm typing:

cvt 1920 1080 60

which produces 'mode lines' which I can use to add new mode through xrandr and then add this mode.

Since xrandr doesn't remember settings after session restart, I created a .desktop file in ~/.config/autostart .desktop file runs script which consist following lines:

#!/bin/bash

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode DVI-I-1 "1920x1080_60.00"
xrandr --output DVI-I-1 --mode "1920x1080_60.00"
edit flag offensive delete link more

Comments

My .desktop file looks as follows:

[Desktop Entry] Name=startup GenericName=startup Comment=Start these up at login Exec=/home/myAccount/Adjust_Resolution.sh Terminal=False Type=Application X-GNOME-Autostart-enabled=true Name[pl_PL]=AdjustScreen.desktop

MateuszK gravatar imageMateuszK ( 2016-02-18 12:19:36 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-02-15 14:36:57 -0500

Seen: 2,145 times

Last updated: Feb 18 '16