Ask Your Question
0

Fedora 23 - Something is eating my folders

asked 2016-02-11 08:23:07 -0500

zarnad gravatar image

updated 2016-02-12 22:21:59 -0500

mether gravatar image

The usual folders: Downloads, Documents, Pictures, Music were not present when I installed Fedora 23. I manually added them to my home folder, but if I don't put something in them they disappear when I boot my machine.

I received a pop-up message about the Downloads folder:

Configured directory for incoming files does not exist Please make sure that directory "/home/xxx/Downloads" exists or configure it with blueman-services.

edit retag flag offensive close merge delete

Comments

My results:

Package xdg-user-dirs-gtk-0.10-8.fc23.x86_64 is already installed, skipping.

It appears that I already have that package so the absence of it is not causing my problem.

zarnad gravatar imagezarnad ( 2016-02-11 10:41:05 -0500 )edit

If you create some other folder does it also disappear after reboot or just the "default ones"?

masteroman gravatar imagemasteroman ( 2016-02-11 11:08:25 -0500 )edit

As far as I know, it's only been the default ones.

I just now added a new folder to /home/myname/Apples and also added a curves folder to .gimp-2.8 named, curves. Both left empty. Then restarted my machine. The two folders are still there.

zarnad gravatar imagezarnad ( 2016-02-11 12:09:10 -0500 )edit

you may also try sudo dnf reinstall xdg-user-dirs-gtk

florian gravatar imageflorian ( 2016-02-11 12:36:32 -0500 )edit

Weird. Can youplease post contents of user-dirs.dirs file? cat ~/.config/user-dirs.dirs

masteroman gravatar imagemasteroman ( 2016-02-11 14:05:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-12 14:45:41 -0500

masteroman gravatar image

As I though, basically your user-dirs.dirs should look like:

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

Try changing your file like that and see what happens. (to edit file use gedit ~/.config/user-dirs.dirs )

edit flag offensive delete link more

Comments

When I run gedit ~/.config/user-dirs.dirs, I get a blank document. user-dirs.dirs resides in /usr/share/man/man5/user-dirs.dirs.5.gz

zarnad gravatar imagezarnad ( 2016-02-13 01:03:35 -0500 )edit

I should have told you at the start that I am running MATE desktop. I went to my home folder/config and opened the file in Pluma. I edited it like the one you have up there and saved it. I booted. All the changes I made were gone. I tried running the command in the terminal window and this time the file opened and I made the changes you said to. pluma ~/.config/user-dirs.dirs After making the changes, I booted and the changes were no longer in the file. That's three times the changes got deleted.

Still no joy.

zarnad gravatar imagezarnad ( 2016-02-13 08:34:54 -0500 )edit

Those are two different things:

  • user-dirs.dirs has to go to ~/.config/. So fill this empty document with life as suggested by @masteroman in this answer.

  • /usr/share/man/... contains manuals (also called man pages) for many many GNU Linux commands and configurations. If, for example, your are interested in the manual for the user-dirs configuration, just type: man user-dirs.dirs, man user-dirs.defaults, and man user-dirs.conf. (q to quit).

florian gravatar imageflorian ( 2016-02-13 10:05:47 -0500 )edit

By the way, you can also check the file /etc/xdg/user-dirs.defaults (sudo gedit /etc/xdg/user-dirs.defaults) and see what it contains. If it looks similar to what's posted here, just run xdg-user-dirs-update and you should be good!

florian gravatar imageflorian ( 2016-02-13 10:10:23 -0500 )edit
1

I ran the update command. I do not use sudo, but I did sign in as root. This is the result of those commands: [root@localhost ~]# gedit /etc/xdg/user-dirs.defaults (It had the same as to what is posted here)

* (gedit:3345): WARNING *: Set document metadata failed: Setting attribute metadata::gedit-position not supported [root@localhost ~]# xdg-user-dirs-update

It did not update the /home/(my name)/.config/user-dirs.dirs file.

zarnad gravatar imagezarnad ( 2016-02-13 12:47:28 -0500 )edit
0

answered 2016-02-11 08:44:54 -0500

geforce gravatar image

Try installing xdg-user-dirs-gtk package

sudo dnf install xdg-user-dirs-gtk
edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-02-11 08:23:07 -0500

Seen: 1,072 times

Last updated: Feb 12 '16