Ask Your Question
1

fedora 18 joystick not working

asked 2013-02-01 22:17:11 -0500

greg gravatar image

updated 2014-09-28 23:43:23 -0500

mether gravatar image

USB joystick is not working on fedora 18. Worked fine on 17 There is no /dev/input/js0 and yum update joystick-support did not solve the problem. Did a yum install module-init-tools but can't do yum install joystick because linuxconsoletools is installed.

Please help

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-03-05 21:31:44 -0500

ryanlerch gravatar image

From Fedora 17 onwards, the joystick drivers (that are in the kernel) were put into a separate package that is now installed by default. So to get the drivers for your joystick, you need to:

sudo yum install kernel-modules-extra

also, once you have done this, install the following package to test if the system is recognising your joystick:

sudo yum install joystick

once the joystick package is installed, run the following command from your terminal

jstest --event /dev/input/js0

and then press buttons or move the joystick around. Output should print to the terminal that input is being recieved from the joystick (this means its working!) note try other js numbers like js1 or js2 if this doesn't work at first.

edit flag offensive delete link more

Comments

If it is an USB joystick you could execute from the command line lsusb to see, if the thing was recognized. And then lsmod | grep joy to see, if the module joydev was loaded, which is responsible for joystick handling.

erik gravatar imageerik ( 2013-03-07 06:07:24 -0500 )edit

Need to install linuxconsoletools in Fedora 20.

robertc gravatar imagerobertc ( 2014-01-24 19:44:52 -0500 )edit
0

answered 2013-06-22 08:38:11 -0500

az gravatar image

i tried all of the above, but there is no /dev/input/js0 ...

The module 'joydev' is loaded though.

edit flag offensive delete link more
0

answered 2013-03-05 09:25:24 -0500

Froller gravatar image

updated 2013-03-05 09:26:52 -0500

The solution is:

# yum install kernel-modules-extra joystick-support
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-02-01 22:17:11 -0500

Seen: 5,244 times

Last updated: Jun 22 '13