Wifi not working on fedora 23

asked 2016-02-08 08:31:19 -0500

slox gravatar image

Hi all, I've some problems with my wifi card (intel 7260 N). iwconfig show

$> iwconfig
enp0s0    no wireless extensions.

lo        no wireless extensions.
 
the ucode-files are in the right directory:
$> ls /usr/lib/firmware/iwlwifi-7260-*
/usr/lib/firmware/iwlwifi-7260-10.ucode  /usr/lib/firmware/iwlwifi-7260-16.ucode
/usr/lib/firmware/iwlwifi-7260-12.ucode  /usr/lib/firmware/iwlwifi-7260-7.ucode
/usr/lib/firmware/iwlwifi-7260-13.ucode  /usr/lib/firmware/iwlwifi-7260-8.ucode
/usr/lib/firmware/iwlwifi-7260-14.ucode  /usr/lib/firmware/iwlwifi-7260-9.ucode 

dmesg show:


$> dmesg | grep iwlwifi 
[    5.833653] iwlwifi 0000:00:01.0: Hardware error detected.  Restarting.
[    5.833663] iwlwifi 0000:00:01.0: CSR values:
[    5.833666] iwlwifi 0000:00:01.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[    5.833675] iwlwifi 0000:00:01.0:        CSR_HW_IF_CONFIG_REG: 0X40489204
[    5.833682] iwlwifi 0000:00:01.0:          CSR_INT_COALESCING: 0X80000040
[    5.833689] iwlwifi 0000:00:01.0:                     CSR_INT: 0X20000000
[    5.833697] iwlwifi 0000:00:01.0:                CSR_INT_MASK: 0X00000000
[    5.833704] iwlwifi 0000:00:01.0:           CSR_FH_INT_STATUS: 0X00000000
[    5.833712] iwlwifi 0000:00:01.0:                 CSR_GPIO_IN: 0X00000000
[    5.833718] iwlwifi 0000:00:01.0:                   CSR_RESET: 0X00000009
[    5.833726] iwlwifi 0000:00:01.0:                CSR_GP_CNTRL: 0X080003c5
[    5.833733] iwlwifi 0000:00:01.0:                  CSR_HW_REV: 0X00000144
[    5.833740] iwlwifi 0000:00:01.0:              CSR_EEPROM_REG: 0X00000000
[    5.833747] iwlwifi 0000:00:01.0:               CSR_EEPROM_GP: 0X80000000
[    5.833754] iwlwifi 0000:00:01.0:              CSR_OTP_GP_REG: 0X803a0000
[    5.833762] iwlwifi 0000:00:01.0:                 CSR_GIO_REG: 0X00080046
[    5.833769] iwlwifi 0000:00:01.0:            CSR_GP_UCODE_REG: 0X00000000
[    5.833778] iwlwifi 0000:00:01.0:           CSR_GP_DRIVER_REG: 0X00000000
[    5.833787] iwlwifi 0000:00:01.0:           CSR_UCODE_DRV_GP1: 0X00000000
[    5.833795] iwlwifi 0000:00:01.0:           CSR_UCODE_DRV_GP2: 0X00000000
[    5.833804] iwlwifi 0000:00:01.0:                 CSR_LED_REG: 0X00000018
[    5.833814] iwlwifi 0000:00:01.0:        CSR_DRAM_INT_TBL_REG: 0X00000000
[    5.833822] iwlwifi 0000:00:01.0:        CSR_GIO_CHICKEN_BITS: 0X27800200
[    5.833830] iwlwifi 0000:00:01.0:             CSR_ANA_PLL_CFG: 0Xd55555d5
[    5.833838] iwlwifi 0000:00:01.0:      CSR_MONITOR_STATUS_REG: 0X3c0c019c
[    5.833847] iwlwifi 0000:00:01.0:           CSR_HW_REV_WA_REG: 0X0001001a
[    5.833855] iwlwifi 0000:00:01.0:        CSR_DBG_HPET_MEM_REG: 0Xffff0000
[    5.833860] iwlwifi 0000:00:01.0: FH register values:
[    5.833879] iwlwifi 0000:00:01.0:         FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X3eafac00
[    5.833900] iwlwifi 0000:00:01.0:        FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X03d8de90
[    5.833922] iwlwifi 0000:00:01.0:                  FH_RSCSR_CHNL0_WPTR: 0X000000f8
[    5.833943] iwlwifi 0000:00:01.0:         FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X80801114
[    5.833965] iwlwifi 0000:00:01.0:          FH_MEM_RSSR_SHARED_CTRL_REG: 0X0000003c
[    5.833986] iwlwifi 0000:00:01.0:            FH_MEM_RSSR_RX_STATUS_REG: 0X07030000
[    5.834015] iwlwifi 0000:00:01.0:    FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[    5.834036] iwlwifi 0000:00:01.0:                FH_TSSR_TX_STATUS_REG: 0X05ff0000
[    5.834057] iwlwifi 0000:00:01.0:                 FH_TSSR_TX_ERROR_REG: 0X00000000
[    5.834064] iwlwifi 0000:00:01.0: Not valid error log pointer 0x00000000 for Init uCode
[    7.516049] iwlwifi 0000:00:01.0: Failed to load firmware chunk!
[    7.516056] iwlwifi 0000:00:01.0: Could not load the [0] uCode section
[    7.516072] iwlwifi 0000:00:01.0: Failed to start INIT ucode: -110
[    7.516773] iwlwifi 0000:00:01.0: Failed to run INIT ucode: -110
[    7.517375] iwlwifi 0000:00:01.0: L1 Enabled - LTR Enabled ...
(more)
edit retag flag offensive close merge delete

Comments

Uh.

I assume your system is up-to-date. You may want to take a look at this page https://wireless.wiki.kernel.org/en/u... , and

  • maybe download the newest firmware
  • and read About iwldvm support and known issues (I don't think that is the problem)

Looks similar to this one https://lists.debian.org/debian-kerne... and this one https://bbs.archlinux.org/viewtopic.p...

florian gravatar imageflorian ( 2016-02-09 16:37:50 -0500 )edit