Ask Your Question
1

How do I allow Deluge (or any torrent client) through firewalld in Fedora 18?

asked 2013-01-23 10:28:59 -0500

jackhall gravatar image

updated 2013-08-26 12:25:59 -0500

ryanlerch gravatar image

I've tried both the command line interface and the GUI, and neither one will allow me to open any ports. Although the GUI displays them as allowed, when I probe for open ports with nmap there are no new ones. Also, both Deluge and Transmission have a "check active port" button in the preferences, and both checks fail no matter what I do to firewalld in the GUI or in the command line. As far as I can tell, this could be a bug in firewalld, SELinux could be doing something weird behind the scenes, or I'm just an idiot. Could anybody tell me which? Thanks!

edit retag flag offensive close merge delete

Comments

I have the same problem - did this get resolved?

LikeLinux gravatar imageLikeLinux ( 2013-01-28 12:57:20 -0500 )edit

I totally deleted firewalld & firewall-config plus disabled SELinux and still could not get any bittorrent client work (Tranny, Azureus, Deluge). It is not the router as my wife's laptop has no problem with Deluge running in Mint. I had no problem in 17.

godless2 gravatar imagegodless2 ( 2013-01-30 00:21:54 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-23 13:19:34 -0500

hhlp gravatar image

updated 2013-01-24 07:40:34 -0500

open firewlld GUI and then open port you would like to use :

image description

in deluge disable random ports and use fixed ports like the image :

image description

do the same in transmision :

image description

IMPORTANT : I use the command line :

sudo firewall-cmd --permanent --zone=public --add-port=60000/tcp
sudo firewall-cmd --permanent --zone=public --add-port=60000/udp
sudo firewall-cmd --permanent --zone=public --add-port=61000/tcp
sudo firewall-cmd --permanent --zone=public --add-port=61000/udp
sudo firewall-cmd --permanent --zone=public --add-port=62000/tcp
sudo firewall-cmd --permanent --zone=public --add-port=62000/udp

NOTE : FIREWALLD Documentation and man firewalld and firewall-cmd

edit flag offensive delete link more

Comments

please update your post with this command in terminal -> sudo firewall-cmd --list-all-zones

hhlp gravatar imagehhlp ( 2013-01-28 15:36:42 -0500 )edit
-1

answered 2013-08-02 08:20:10 -0500

you all try to open ports 6xxxx ant whats your BT-client setting??

I know that that's number varies depending on a client (sometimes session) - check settings.

Some SOHO (especially tplink) routers have problems the same ports are used for services on different machines of the LAN side - permanent port forwarding doesn't work either) (check: -routers: uPnP, forwarding -setting/status, - BT's uPnP setting - firewall: upnp setting ) )

Try to assign a different zone to your connection.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-23 10:28:59 -0500

Seen: 13,675 times

Last updated: Aug 26 '13