Ask Your Question

Fedora 23: WiFi was working during anaconda installation, but now it's gone

asked 2016-02-05 01:58:03 -0500

cageygee3 gravatar image

updated 2016-02-05 21:04:53 -0500

mether gravatar image

During the Anaconda installation of Fedora 23 Server (minimal install), my onboard WiFi card was detected and I was able to connect to my home wireless network and even enable network time. After the installation finished and the computer booted into the OS, the WiFi configuration is now gone.

The WiFi card appears in the output of lspci, but not in the output of ifconfig (only Ethernet and loopback show up there).

What's the next step here? I'm planning on this being a headless server, so I don't have a GUI or any graphical apps installed, just the command line.

edit retag flag offensive close merge delete


What is the output of lspci -v and lspci -n of your WiFi card?
Looks like a driver is missing.

thomaswood gravatar imagethomaswood ( 2016-02-05 04:52:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-05 08:38:49 -0500

Because Minimal Install doesn't install NetworkManager-wifi and wpa_supplicant packages. Install these package with DNF, sudo dnf install NetworkManager-wifi wpa_supplicant or if you are offline, then grab the .rpm packages from other computer that has internet connection, copy those packages to your computer and install them with RPM or DNF.

edit flag offensive delete link more


Ah, that would explain it! Okay, so I downloaded those packages on another computer, copied them over via a USB drive, and tried to install one of them, but it's still not working because dnf is expecting an Internet connection. I'll post the output in the next comment because there's a 500 character limit.

cageygee3 gravatar imagecageygee3 ( 2016-02-05 11:59:38 -0500 )edit

Here's the output:

[root@localhost sdb1]# dnf install NetworkManager-1.0.10-2.fc23.x86_64.rpm
Error: Failed to synchronize cache for repo 'fedora' from '': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for [Could not resolve host:]

How do I tell dnf to just install the package? I tried rpm but it doesn't work.

cageygee3 gravatar imagecageygee3 ( 2016-02-05 12:00:55 -0500 )edit

dnf --disablerepo=\* install ./NetworkManager-1.0.10-2.fc23.x86_64.rpm

alunux gravatar imagealunux ( 2016-02-07 10:58:19 -0500 )edit

Question Tools

1 follower


Asked: 2016-02-05 01:58:03 -0500

Seen: 758 times

Last updated: Feb 05 '16