After booting log in screen appears , after typing password log in screen is redirected to log in screen itself and not to the desktop?

asked 2016-02-03 00:34:22 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I'm a newbie to Fedora and have recently switched from debian to Fedora23. I installed oracle java 1.8.72 and set the path in /etc/environment/ and installed scala when last time I used my system after which I'm facing the login Problem. LOG IN screen is redirected to log in screen again after typing correct password. I logged in via shell ctrl+alt+f2 as root initially problems were listed as curl error(6): host name un resolved could not found file virtualbox_asc . Error-log file is not accessible so I reset home folder by restorecon -R /home command but it's not a help. but now the error is /usr/libexec/grep error : line 5 grep command not found would you like to install packages ? tried to update the system dnf command not found would you like to install packages sedo command not found would you like to install packages when pressed yes it says an advanced version is already installed. I have my important project files in the system and don't want to format the system. Please help. Thanks in advance. P.S. : It's a dual boot system with windows 8.1.

edit retag flag offensive close merge delete

Comments

What exactly did you put into /etc/environment? This looks like you did something like PATH=<path-to-jre> instead of PATH=$PATH:<path-to-jre>.

thomaswood gravatar imagethomaswood ( 2016-02-03 03:04:55 -0600 )edit

I added these three statements in that file: export PATH=$PATH:/opt/jdk1.8.0_72/bin:/opt/jdk1.8.0_72/jre/bin export JRE_HOME=/opt/jdk1.8.0_72/jre export JAVA_HOME=/opt/jdk1.8.0_72

simpreetam gravatar imagesimpreetam ( 2016-02-03 03:26:00 -0600 )edit

Hm...funny, just also did to try to extend my $PATH through /etc/environment which cut off /usr/local/bin and /usr/bin giving me the same errors. I think best would be to remove these entries from /etc/environment again and put the settings into a seperate file in /etc/profile.d/ or use the alternatives method.

thomaswood gravatar imagethomaswood ( 2016-02-03 07:26:44 -0600 )edit