Ask Your Question
0

How do I permanently disable upower? I have tried: systemctl disable upower

asked 2016-02-02 18:41:02 -0500

smoyse gravatar image

upower is getting segfaults, and once even stopped Firefox from starting.

I have tried to disable upower with:

systemctl disable upower

Everytime I reboot though upower starts up.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-02 21:31:07 -0500

sideburns gravatar image

Welcome to ask.fedora. Have you tried creating a bug report for this issue at the Fedora Bugzilla? If not, you probably should, and put a link to it here so that any others who are interested can follow it. Disabling the service only stops it from starting on its own; other services or programs can still start it if they need to. If you really want upower to be completely deactivated, you need to do this, as root: systemctl mask upower which will keep it from being loaded unless you unmask it again.

Hope this helps, and please keep us informed.

edit flag offensive delete link more

Comments

Thanks, exactly what I needed. I will try to log a bug report, but F23 is the least stable Fedora release I can remember, even the kde crash reporter crashes.

smoyse gravatar imagesmoyse ( 2016-02-03 20:20:31 -0500 )edit

Question Tools

Stats

Asked: 2016-02-02 18:41:02 -0500

Seen: 1,141 times

Last updated: Feb 02 '16