Ask Your Question
0

Can not find kernel sources for 4.3.4-300.fc23.x86_64

asked 2016-02-02 07:19:53 -0500

capira gravatar image

updated 2016-02-08 22:28:39 -0500

mether gravatar image

Hi all.

While trying to install VirtualBox in a clean install, I found an error because, latest kernerl sources founded at /usr/src/kernels does not match which the one running

# uname -a
Linux HR-PC-004878 4.3.4-300.fc23.x86_64 #1 SMP Mon Jan 25 13:39:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

# ll /usr/src/kernels/
total 8,0K
drwxr-xr-x. 23 root root 4,0K feb  2 12:40 4.3.3-303.fc23.x86_64
drwxr-xr-x. 23 root root 4,0K feb  2 13:10 4.3.3-303.fc23.x86_64+debug

# rpm -qa kernel* | sort -V 
kernelshark-2.2.1-6.fc23.x86_64
kernel-4.3.3-301.fc23.x86_64
kernel-4.3.3-303.fc23.x86_64
kernel-4.3.4-300.fc23.x86_64
kernel-core-4.3.3-301.fc23.x86_64
kernel-core-4.3.3-303.fc23.x86_64
kernel-core-4.3.4-300.fc23.x86_64
kernel-debug-4.3.3-303.fc23.x86_64
kernel-debug-core-4.3.3-303.fc23.x86_64
kernel-debug-devel-4.3.3-303.fc23.x86_64
kernel-debug-modules-4.3.3-303.fc23.x86_64
kernel-debug-modules-extra-4.3.3-303.fc23.x86_64
kernel-devel-4.3.3-303.fc23.x86_64
kernel-headers-4.3.4-300.fc23.x86_64
kernel-modules-4.3.3-301.fc23.x86_64
kernel-modules-4.3.3-303.fc23.x86_64
kernel-modules-4.3.4-300.fc23.x86_64
kernel-modules-extra-4.3.3-303.fc23.x86_64
kernel-rpm-macros-36-1.fc23.noarch
kernel-tools-4.3.3-303.fc23.x86_64
kernel-tools-libs-4.3.3-303.fc23.x86_64
kernel-tools-libs-devel-4.3.3-303.fc23.x86_64

Any ideas?

Thanks in advance.

Best regards.

edit retag flag offensive close merge delete

Comments

1

try running

sudo dnf reinstall kernel-devel

Do that while running on kernel version 4.3.4-300

aeperezt gravatar imageaeperezt ( 2016-02-02 08:39:04 -0500 )edit

I think something is broken somewhere ...

# dnf reinstall kernel-devel 
Last metadata expiration check performed 0:00:00 ago on Tue Feb  2 16:06:26 2016.
Installed package kernel-devel-4.3.3-303.fc23.x86_64 (from updates) not available.
Error: Nothing to do.

# uname -r
4.3.4-300.fc23.x86_64
capira gravatar imagecapira ( 2016-02-02 09:09:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-02 11:52:32 -0500

capira gravatar image

Following suggested related question on the right panel of this forum, I found a comment in this question that help me solved the problem.

Basically what I did was:

# dnf install kernel-devel-$(uname -r)
# dnf reinstall VirtualBox-5.0

And know everything seems to be ok.

Thanks to all.

edit flag offensive delete link more

Comments

Thank you for posting.

Sebas gravatar imageSebas ( 2016-09-15 05:30:13 -0500 )edit

I wroted the same command but ...

[root@localhost ~]# dnf install kernell-devel-$(uname -r) Last metadata expiration check: 2:49:04 ago on Fri Mar 3 04:37:53 2017. No package kernell-devel-4.9.12-200.fc25.x86_64 available. Error: Unable to find a match.

[root@localhost ~]# rpm -qa kernel* | sort -V kernel-4.8.6-300.fc25.x8664 kernel-4.9.12-200.fc25.x8664 kernel-core-4.8.6-300.fc25.x8664 kernel-core-4.9.12-200.fc25.x8664 kernel-headers-4.9.12-200.fc25.x8664 kernel-modules-4.8.6-300.fc25.x8664 kernel-modules-4.9.12-200.fc25.x8664 kernel-modules-extra-4.8.6-300.fc25.x8664 kernel-modul

achede_hd gravatar imageachede_hd ( 2017-03-03 09:35:10 -0500 )edit

Thanks capira. I am able to install both VirtualBox and VmWare Player with the commands you suggested.

Baddi gravatar imageBaddi ( 2017-03-13 09:39:50 -0500 )edit

Thanks a lot!!! Finally got this problem solved...

ronaldo gravatar imageronaldo ( 2017-09-05 09:23:19 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-02-02 07:19:53 -0500

Seen: 6,113 times

Last updated: Feb 02 '16