Ask Your Question
0

gnome-software ignore proxy settings

asked 2016-01-29 22:50:37 -0500

tt gravatar image

I'm using fedora23 at required proxy.

I set proxy address to /etc/profile, dnf, wget. but I can install nothing by gnome-software.

It seem to connecting direct. (according to netstat)

Where to set proxy address for gnome-software?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-01-30 06:52:17 -0500

For Gnome3 you have to use the gsettings interface and the scheme is org.gnome.system.proxy.

Here is a little how-to for these settings.

edit flag offensive delete link more
0

answered 2016-01-30 09:02:25 -0500

tt gravatar image

Thank you for teach me about gsettings.

I can't confirm the machine not now (only on weekday), but I think i was set proxy for browser by using gnome-control-center, (on custom user's desktop) and result of "gsettings get org.gnome.system.proxy mode" should become "manual".

so,,, I guess,,, I have to execute gsettings by root user?

edit flag offensive delete link more

Comments

Just saw that there also should be a tool dconf-editor which is a graphical tool. The settings are user based, so you do not have to execute that as root.

thomaswood gravatar imagethomaswood ( 2016-01-31 04:48:30 -0500 )edit

Excuse my late reply.

As a result, "sudo gsettings ..." was not effect.

There were still processes like bellow.

tcp        0      1 localhost.localdo:54346 fedoraproject.org:http  SYN_SENT    969/NetworkManager 
tcp        0      1 localhost.localdo:59582 proxy09.fedorapro:https SYN_SENT    1614/packagekitd

And, I did "ndf update", it solved (I can install apps by gnome-software) for some reason.

"packagekitd" become to connect to proxy, but, "NetworkManager" still try to connect direct.``

tt gravatar imagett ( 2016-02-01 20:33:43 -0500 )edit

Question Tools

Stats

Asked: 2016-01-29 22:50:37 -0500

Seen: 1,871 times

Last updated: Jan 30 '16