Ask Your Question
1

I need to disable the left Shift key

asked 2016-01-23 11:13:22 -0500

Adam Jensen gravatar image

For some reason the left shift on my Thinkpad x200s is pressed when I press the A, the Z and the < keys.

The problem can be resolved opening the keyboard but I don't have the time nor the dexterity without spending 40€ for a repair. I have read some website about tinkering with xmodmap/XKB to remap the keyboard, so i want to know how to modify these setting to disable the left shift that cause so much problem when I need to type passwords and commands in terminal.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2016-01-25 09:14:42 -0500

Aeyoun gravatar image

Some Lenovo keyboards have problems with rollover keys, which can manifest like what you’re describing. More likely, it just some grit in your keyboard. Turn off the computer, flip it up-side-down, and give it a good shaking! You can also try cleaning between the keys wit ha pin to extract hairs and grit.

No luck with analog solutions? Run the xev command, press the keys, and confirm what events are actually fired when you press one of the affected keys.

edit flag offensive delete link more
0

answered 2016-01-25 05:31:04 -0500

usb keyboard till a better ans comes along

edit flag offensive delete link more

Comments

useless. would downvote here if I could.

hannsandersson gravatar imagehannsandersson ( 2016-01-26 21:42:54 -0500 )edit

Question Tools

Stats

Asked: 2016-01-23 11:13:22 -0500

Seen: 142 times

Last updated: Jan 25 '16