Ask Your Question

Dell Inspiron 7559 and Fedora 23 Cinnamon spin video drivers issues

asked 2016-01-14 04:46:36 -0500

Muntaner gravatar image

updated 2016-01-24 23:05:57 -0500

mether gravatar image

I just installed Fedora 23 Cinnamon spin on my new Dell Inspiron 7559 (it is equipped with an I7-6700HQ and a Nvidia GeForce GTX960m 4GB).

The laptop came with Windows 10 pre-installed: I added an M2 SSD 250GB (it has a free M2 slot) and moved the OS on it, leaving his 1TB drive as an archive partition. Then, I wanted to add Fedora 23 Cinnamon spin in dual-boot with it.

The bootable usb (created with Rufus) immediately gave me problems: it could not start with the options "Start Fedora Live" or the "Test this media and start Fedora Live" since in both options it got frozen at the end of Fedora logo's loading. Starting the bootable usb via the "Troubleshooting" -> "Start Fedora Live with minimal graphic environment" worked, and I could successfully install Fedora 23 Cinnamon spin with the minimal graphics in dual boot with my Windows 10.

Everytime I start the OS, Cinnamon tells me that it started in Software Rendering mode, and tells me that there is some driver issue. It works at full resolution (1920*1080), but naturally it uses a lot of CPU and lags with some applications (IDEs or similar), and the HDMI port isn't working (I'm sure it works since I can normally use it in Windows).

The first thing I tried to do was to install Bumblebee following this guide: but, at a certain point, this broke my system: 1) Starting the computer with Secure Boot disabled resulted in an hard freeze of the laptop just before the login screen and after the Fedora logo loading (had to press the power button to turn off my pc by force). I noticed that in this situation with the 5-10% of probability it loaded the login screen, but after the login the system is unusable, with heavy lags and panels, terminals, menus not opening at all. 2) Starting the computer without Secure Boot resulted in a console boot, without graphical environment. I solved this situation by doing a "dnf remove *nvidia*\".

Now, with Secure Boot activated, the system starts in Software Rendering mode. With Secure Boot deactivated, it hard freezes.

I played around with the Secure Boot stuff since I noticed that the system could not load the "bbswitch" module with it activated: I guess that in this moment, when Secure Boot is activated, it fails to load bbswitch and so the system starts in Software Rendering mode.

At this point I'm quite lost, since I'm not an expert in kernel's or driver's managing. Fedora is fully updated (4.3.3 kernel released yesterday).

I can post any logs that may help to diagnose this situation.

Here it is my Xorg.0.log:

I'd like to use the Nvidia GPU, but also using the Intel graphics can be fine: I just would like to get out from this Software Rendering situation.

this is what I did:

1 ... (mas)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-01-15 11:52:42 -0500

Muntaner gravatar image

updated 2016-01-15 11:53:00 -0500

For anyone facing this problem, I think I solved it (can't get if I solved it permanently).

I uninstalled everything bumblebee-related. But I think the solution has been deleting the "nomodeset" kernel parameter by the boot GRUB entry. Kernel 4.3.3.

Now my Fedora isn't starting in software rendering mode and HDMI seems to be working!

edit flag offensive delete link more


actually what works for me was adding "modprobe.blacklist=nouveau" in fedora 25 and a dell inspiron 7559. Thanks :)

gersiov gravatar imagegersiov ( 2017-03-16 02:31:05 -0500 )edit

Question Tools

1 follower


Asked: 2016-01-14 04:46:06 -0500

Seen: 1,066 times

Last updated: Jan 15 '16