Ask Your Question
0

yum not working. I keep getting trying another mirror messages.

asked 2016-01-10 01:09:14 -0500

gaur gravatar image

Whenever i run yum command i get this error https://deb.torproject.org/torproject.org/rpm/DISTRIBUTION/x86_64/repodata/repomd.xml: [Errno 12] Timeout on https://deb.torproject.org/torproject.org/rpm/DISTRIBUTION/x86_64/repodata/repomd.xml: (28, 'Resolving timed out after 30537 milliseconds') Trying other mirror.
It was working fine till few weeks ago.

edit retag flag offensive close merge delete

Comments

2

Welcome to ask.fedora. Fedora 20 is well past its End Of Life (The oldest version currently supported is F 22.) and it's possible that the mirror you're trying to reach is offline. You may be able to correct this by running yum clean all before trying again, but in the long run, you'll be better off upgrading to either F 22 or 23.

sideburns gravatar imagesideburns ( 2016-01-10 02:20:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-10 02:28:24 -0500

Hello

Web pages ( https://www.torproject.org/docs/rpms.... ) says that string DISTRIBUTION should be substitute with one of following: fc/22, fc/23, el/6, el/7. Change the baseurl in your repo configuration to the following one and give it a try again:

https://deb.torproject.org/torproject.org/rpm/fc/$releasever/$releasever/

edit flag offensive delete link more

Comments

1

Thanks to sideburns I just noted it is tagged to F20. There are no packages for F20 anymore. Packages are available for F22 and F23 only: https://deb.torproject.org/torproject...

kukacek gravatar imagekukacek ( 2016-01-10 02:31:36 -0500 )edit

I am new to fedora so i don't know how to update it to fc/22 or fc/23 ??

gaur gravatar imagegaur ( 2016-01-10 05:51:00 -0500 )edit
1

How to update the repo configuration file or how to upgrade Fedora? Btw. just to be sure, which version of Fedora do you run cat /etc/fedora-release?

If you are running Fedora 20, then even updating repo to fc/22 or fc/23 might not work as expected, since packages in those repos are for Fedora 22 and Fedora23. You would need to upgrade your Fedora to one of those releases first.

Btw. tor delivered from Fedora repo is not enough? If you would upgrade Fedora to 22 or 23, there is latest tor version (0.2.7.6) available in Fedora repos (no need to have additional repo to get it).

kukacek gravatar imagekukacek ( 2016-01-11 05:45:02 -0500 )edit

Question Tools

Stats

Asked: 2016-01-10 01:09:14 -0500

Seen: 470 times

Last updated: Jan 10 '16