Bumblebee/Nouveau not working with Steam

asked 2016-01-09 21:09:21 -0500

piccolo gravatar image

Hi there,

I have an MSI GT60-0NC gaming laptop. It has an NVIDIA GTX670M card as well as the integrated Intel graphics, so it has Optimus. I've successfully installed Bumblebee and the optirun command works fine on its own (glxgears has around 60fps whereas optirun glxgears has 1,290fps). According to this article on Steam's website, I am supposed to tell Steam to run a game with optirun by adding it under Properties -> Set Launch Options. I did that, but I didn't notice an increase in FPS for playing the game (for reference, it's The Talos Principle). I'm still getting around 7-8 fps, the same as with the Intel card.

Edit: Minecraft doesn't have a significant FPS increase with Optirun either. However, it does recognize that it's using the nouveau driver instead of Intel. Actually, looking at it again, I'm averaging less FPS with the nvidia card (15-20 vs 30)

My Setup:

  • Fedora 20
  • uname -a output: Linux laptop 3.19.8-100.fc20.x86_64 #1 SMP Tue May 12 17:08:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
  • optirun version 3.2.1

Do you think uninstalling Nouveau and going to the closed-source NVIDIA graphics card might fix my issues? Maybe updating Fedora? I'm really at a loss as to why this isn't working, any help would be much appreciated! Thanks!

edit retag flag offensive close merge delete