Ask Your Question
0

Plantronics USB headset not appearing as output device in Pulseaudio [closed]

asked 2016-01-09 15:36:31 -0500

I plugged in my Plantronics USB headset, which was previously working with Linux on an older laptop, into my laptop, and the light in the headset went on. However, the sound continued to come out of my laptop's speakers, and no sound came out of the headset. Normally, I would use pavuncontrol to redirect the sound from the application producing the sound to the desired audio output, but I was unable to do this because the Plantronics headset does not appear as an output device in pavucontrol. It appears in the "Configuration" tab as "Audio 655 DSP", but it does not appear in the "Output Devices" tab, and it is not selectable as an output device for an application in the "Playback" tab.

However, dmesg, aplay -l and pacmd list all show that both ALSA and Pulseaudio are detecting the headset. sudo fuser -v /dev/snd/* does not show any rogue applications monopolising any ALSA device.

Note: Analogue audio headphones work fine.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Robin Green
close date 2016-01-10 02:29:05.778785

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-10 15:34:06 -0500

updated 2016-01-10 15:41:37 -0500

This is a Pulseaudio bug. The workaround is to type pulseaudio -k and press ENTER in a terminal (which restarts Pulseaudio) while the headset is connected.

edit flag offensive delete link more

Comments

I had this exact problem on ubuntu and I would have never thought of restarting pulseaudio! Thanks :-)

alkemyst gravatar imagealkemyst ( 2018-01-24 06:24:20 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-01-09 15:36:31 -0500

Seen: 3,512 times

Last updated: Jan 10 '16