Ask Your Question
0

Fedora 17: R8168 driver not compiling correctly

asked 2012-11-28 18:31:07 -0500

TheAvidStudent gravatar image

updated 2012-11-28 18:33:35 -0500

Hello all,

I am brand new to the world of Linux, and I am having quite a bit of trouble installing this driver. I am getting an error message upon compilation:

Check old driver and unload it. Build the module and install make[2]: * No rule to make target 'clean'. Stop. make[1]: [clean] Error 2 make: ** [clean] Error 2

I think I know why the autorun.sh is not compiling correctly...because I do not have the kernel devel installed (kernel headers installed properly). I downloaded the most recent kernel devel on another computer because I can not access the internet on my computer with Fedora. When I tried to install it pops an error:

kernel-devel-3.6.7-4.fc17.x86_64 requires perl

I downloaded something called "perl-Module-Install-1.04-1.fc17.noarch.rp" thinking that might be what I need to install but that too pops up with an error message:

perl-Module-Install-1.04-1.fc17.noarch requires perl(Cwd)
perl-Module-Install-1.04-1.fc17.noarch requires perl(Module::Build)
perl-Module-Install-1.04-1.fc17.noarch requires perl(:MODULE_COMPAT_5.14.2)
perl-Module-Install-1.04-1.fc17.noarch requires perl(Fcntl)
perl-Module-Install-1.04-1.fc17.noarch requires perl(File::Path)
perl-Module-Install-1.04-1.fc17.noarch requires perl(strict)
perl-Module-Install-1.04-1.fc17.noarch requires perl(Devel::PPPort)
perl-Module-Install-1.04-1.fc17.noarch requires perl(ExtUtils::Manifest)
perl-Module-Install-1.04-1.fc17.noarch requires perl(File::Basename)
perl-Module-Install-1.04-1.fc17.noarch requires perl(YAML::Tiny)
perl-Module-Install-1.04-1.fc17.noarch requires perl(vars)
perl-Module-Install-1.04-1.fc17.noarch requires perl(File::Remove)
perl-Module-Install-1.04-1.fc17.noarch requires perl(ExtUtils::ParseXS)
perl-Module-Install-1.04-1.fc17.noarch requires perl(File::Spec)
perl-Module-Install-1.04-1.fc17.noarch requires perl(ExtUtils::MakeMaker)
perl-Module-Install-1.04...

So I assume I am trying to install the incorrect thing. I cannot take advantage of the easy yum command to install perl, and I am completely new to the world of Linux so any help is much appreciated.

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-05 00:02:12 -0500

Just for the sake of clearing this from the "unanswered" filter; Fedora 17 is no longer supported. Upgrade to Fedora 20 and report back if the problem persists.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-11-28 18:31:07 -0500

Seen: 705 times

Last updated: Apr 05 '14