Ask Your Question
0

Fedora 16 Installation fails on Dell Optiplex 390

asked 2011-12-28 19:37:18 -0500

RayM@UniqueSoft gravatar image

updated 2011-12-30 10:34:02 -0500

hhlp gravatar image

Anyone have a fix for this problem?

I have a new (MFG date 12/21/11) Dell Optiplex 390 with a TSSTcorpDVD-ROM TS-H353C DVD-ROM. In the BIOS, the SATA chip is enabled (only options are Disabled and ATA). The DVD drive is plugged into the white SATA connector on the motherboard. I am unable to installed Fedora 16 x86_64 on this machine. It appears that the installation software (kernel?) does not see the DVD drive (I never get prompted to verify the DVD installation media & the installer doesn't detect the repository on the installation DVD) and it also fails to download from the repositories on the internet. DVD is known good (used successfully several times previously). The installer does see the SATA hard drive. The installer claims that I have a p4p1 controller: Realtek RTL8111/8168B PCI Express card.

Errors I get when booting the installer:

[0.450766] pnp 00:0b can't evaluate _CRS: 12311

As I said, I do not get prompted to test the DVD install media. The installer does see the correct MAC address for the ethernet controller, and sees the hard drive. Later in the install, the installer somehow checks for dependencies, but then cannot download (any?) of the RPM's (it fails on the firewall RPM), then says "Retry Download".

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-12-30 13:51:12 -0500

RayM@UniqueSoft gravatar image

I have posted a bug report, as requested. The URL is: https://bugzilla.redhat.com/show_bug.cgi?id=770990

I have found a workaround, which requires quite a bit of effort on the user's part, but it does work. It involves the following:

  • Create a local Fedora repository (and specify it during the install). You'll need quite a bit of disk space.
  • Change the default BIOS setting from "Legacy Boot" to "UEFI" boot (or hit F12 during the boot process, and specify a UEFI boot from the installation DVD). A UEFI boot is required because the legacy boot does not allow you to add repositories during the install, for some reason.
  • When you are able to, during the installation, deselect the external Fedora repositories, and then add your local repository. This can be a bit tricky. I used NFS and added 2 repositories (one for the base distribution, and one for the updates). The directories you need to specify are:
  • BaseDir/releases/16/Everything/x86_64/os
  • BaseDir/updates/16/x86_64

Two advantages to doing things this way is that the install is faster and when complete, you'll have all of the updates installed as well.

I never could get the installer to recognize the SATA DVD, nor access the remote Fedora repositories on the internet.

The good news is that once you successfully install Fedora 16, with the updates, Fedora seems to run fine on the new hardware.

edit flag offensive delete link more
0

answered 2011-12-29 21:38:55 -0500

FranciscoD_ gravatar image

Not sure. I'd suggest you file a bug against anaconda on bugzilla.redhat.com. The maintainers would be in a better position to assist you. Please do paste the bug link here when you do.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-12-28 19:37:18 -0500

Seen: 1,922 times

Last updated: Dec 30 '11