Ask Your Question
0

How do I make Fedora recognize when I have unplugged my headphones?

asked 2015-12-28 13:52:24 -0500

Chipsz gravatar image

updated 2015-12-28 19:01:30 -0500

Hello!

On my Asus laptop I am running Fedora 23 Workstation 64bit.

Previously the laptop speakers worked, but after booting today (to go online and watch videos) the speakers are no longer being picked up by the system. The sound settings only recognize headphones and refuses to acknowledge when I unplug the headphones. The only way to get sound right now is by using headphones.

If there is any other info anyone needs please let me know how to get it (I.E what to type in CLI to get desired info etc)

Any help would be appreciated, Cheers.

Edit: Things done since installation of Fedora:

  • install Google Chrome
  • Install Flash Player
  • Install pavucontrol
edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. What happens if you boot without the headphones plugged in? Do you have pavucontrol installed (PulseAudio Volume Control) and if so, what does it show?

sideburns gravatar imagesideburns ( 2015-12-28 14:35:25 -0500 )edit

thank you for the welcome. I just installed pavucontrol, prior I was using the stock sound GUI that came with this pack. The only things I have done since installing Fedora 23 is add Google Chrome and flash player (if memory serves right). What pavucontrol shows is that "speakers unavailable", so the system knows they are there, it is just confused because it is registering the headphones are plugged in, even when they are not. I have rebooted before but I will do it again and see if anything changes. Thank you :)

Chipsz gravatar imageChipsz ( 2015-12-28 17:35:51 -0500 )edit

in recent light, perhaps this question needs to be changed, because with pavucontrol I can see that Fedora recognizes that the speakers are there, its just seems to be stuck in headphone mode.

Chipsz gravatar imageChipsz ( 2015-12-28 18:59:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-29 07:47:26 -0500

Chipsz gravatar image

updated 2015-12-31 10:26:19 -0500

Ok, so after booting it just now the system now registers when I do and do not have head phones plugged in and the speakers are working fine. I am not sure why it decided to start working, the only thing I can think of is that I fell asleep with my laptop on and not plugged in and i think it died.

edit: Also, in the past few days it did register headphones in when there where not, but plugging in headphones and then unplugging resolved the issue. It seems like a hardware problem, most likely, as this laptop was in not the most dieal storage for a few months.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-12-28 13:52:24 -0500

Seen: 487 times

Last updated: Dec 31 '15