No access to trackpad and keyboard on Fedora 21

asked 2015-12-27 12:29:01 -0500

edie06 gravatar image

I've been using fedora 21 on an external hard drive with an old macbook via refind and everything has been working well. Over xmas i got an a new macbook cos of memory issues...installed refind and i'm able to boot fedora on it. However i've got no access to the keyboard or trackpad so i'm unable to access the settings or terminal or logon for that matter. I've tried on the old computer and the cursor comes up and trackpad work... I enabled auto logon on there hoping i'd be able to keyboard shortcut or tab my way to settings or something on new one but only difference its made is it auto logs on now but still no cursor, trackpad and keyboard still as good as dead...doesn't even light up. Not sure what to do...

Any ideas please will b greatly appreciated... Many thanks

edit retag flag offensive close merge delete


Welcome to ask.fedora. It's possible that there are hardware differences between the two computers that are causing this. Try using a LiveUSB/DVD to see if it works better. And, while you're at it, you probably want to use Fedora 23, as 21 is slightly past its End Of Life and no longer supported.

sideburns gravatar imagesideburns ( 2015-12-27 12:44:04 -0500 )edit