Ask Your Question
0

graphics do not work

asked 2015-12-14 14:40:39 -0600

ulmair gravatar image

updated 2015-12-14 17:14:15 -0600

Hi,

my new laptop drives my crazy. Currently, I am working with a 800x600 display setting. Xrandr and grub resolution settings do not work :-( I have an intel i7 and

lspci -nnk | grep -iA2 vga

00:02.0 VGA compatible controller [0300]: Intel Corporation Sky Lake Integrated Graphics [8086:1916] (rev 07)
    DeviceName:  Onboard IGD
    Subsystem: Pegatron Device [1b0a:2281]

Up to now, I installed the kernel-4.3 because of the "better" hardware support of Sky Lake Graphics. Unfortunately, it is still not detecting my resolution 1920x1080. My additional graphic card is NVIDIA GTX 950M.

lspci -nnk | grep -iA2 3d

01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
    Subsystem: Pegatron Device [1b0a:2281]
    Kernel modules: nouveau

I need no special 3D performance, but I need at least my Laptop resolution of course. I know it is a special configuration, because I have to use bumblebee for complete support. But it do not work for my setting :-(

If someone out there could give me an advice I would be pretty thankful! Maybe I could switch off one device and use just one ...

Thanks a lot, Franz

edit retag flag offensive close merge delete

Comments

If your BIOS supports it, then go ahead and turn off Optimus. I'm not exactly sure if/how this works with UEFI-based systems. Bumblebee for Fedora has always been a pain in the a** for me, as it tended to mess up some of the core shared libraries before/during/after (un)installation.

ILMostro gravatar imageILMostro ( 2015-12-15 02:44:09 -0600 )edit

If your bios supports the switch, you have a chance. My ACER laptop does not support Optimus boards, and i tried any of the solutions offered on the web including bumblebee .. no chance :(

rdtcustomercare gravatar imagerdtcustomercare ( 2015-12-15 05:08:16 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-12-15 16:19:22 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Thanks everyone for your good comments. Finally, I figured out the problem. I removed nomodeset from /etc/default/grup and run sudo grub2-mkconfig -o /boot/grub2/grub.cfg :-)

Jippy ... now I can enjoy this beautiful Linux :-)

edit flag offensive delete link more
-1

answered 2015-12-14 23:40:24 -0600

miguel-sensacion gravatar image

NVidia... :(

You have to run the binary, similar to the desktop gpu install process. Check this out http://linuxg.net/how-to-install-the-...

edit flag offensive delete link more

Comments

It's no big deal to get nvidia drivers running, but of the kernel does not recgonize the nvidia gpu a a gfx card, you can't use it. a 3D acceleratorcard is not supported. I got a 840M on the laptop and no chance to bring it to live.

rdtcustomercare gravatar imagerdtcustomercare ( 2015-12-15 05:09:37 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-12-14 14:40:39 -0600

Seen: 705 times

Last updated: Dec 14 '15