Ask Your Question

Kickstarting from a USB drive - how to specify the repo?

asked 2015-12-12 22:22:52 -0500

sherl0k gravatar image


I'm trying to create a bootable USB drive based off of Fedora 21 and I'm having a bear of an issue specifying where the repository is supposed to be located.

I have in the root of my USB drive a folder labeled 'fedora' and in that, folders split by letter, the RPMs in there. I used 'createrepo' on the directory, so there is a proper repository in that directory.

I've currently attempted the following:

specifying the following in the boot options:

but that did not work. I looked at the kickstart options, attempting to try to install from a harddrive.
harddrive partition=/dev/disk/by-label/INSTALL --dir=/mnt/install/fedora

this also does not work. (the USB is labeled INSTALL).

specifying a url as a file does not work either.

url --url=file:///mnt/install/repo/fedora/

Is this even possible? Has anyone gotten this to work?

edit retag flag offensive close merge delete


Have difficulty in understanding what you are trying to achieve here. Are you trying to create a bootable USB disk and then use this USB disk to kickstart installations on other machines? Also you want to create a repo on the same USB disk and use that repo to install packages on other machines?

anishjp gravatar imageanishjp ( 2015-12-15 05:43:21 -0500 )edit

The thumbdrive is an offline installer - therefore all the packages are on the USB drive. Telling kickstart to actually use the packages /on/ the thumbdrive, getting it to install /to/ a local disk, is the issue I am running it.

sherl0k gravatar imagesherl0k ( 2015-12-19 17:54:33 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-12-15 08:05:42 -0500


You said that folder fedora holding the repo information and the packages is located in the root of the USB drive. Then I would expect that harddrive definition would be something like this

harddrive --partition=sda1 --dir=/fedora

expecting that your USB drive is recognized as sda and the fedora directory is located on first partition of the USB disk. Otherwise modify according your setup.


edit flag offensive delete link more


It doesn't work!!! (at least at Fedora 24)

q2dg gravatar imageq2dg ( 2016-10-27 19:03:06 -0500 )edit

answered 2016-11-03 08:32:25 -0500

Gerben gravatar image

I have a usb stick with a vfat label "sandsk1", and Scientific Linux 6 in /SL6/os. This works for me in the kickstart file:

harddrive --partition=disk/by-label/sandsk1 --dir=/SL6/os

edit flag offensive delete link more

Question Tools


Asked: 2015-12-12 22:22:52 -0500

Seen: 1,035 times

Last updated: Dec 15 '15