Ask Your Question
2

Boot takes >50 seconds on last 4 services

asked 2015-12-10 15:00:10 -0500

Hi,

I've noticed that F23 can take some time to boot, nothing dramatic, but as I'm using a SSD, it slower than I would expect.

From looking at systemd-analyse it appears that these are the main culprits:

    24.457s dnf-makecache.service
     23.136s fstrim.service
     17.389s plymouth-quit-wait.service
     13.340s mlocate-updatedb.service

Trim I'm not all that surprised about, though it still seems a little slow, not sure why Plymouth should take so long, but the main ones that jump out are mlocate and dnf-makecache.

I gather that mlocate can be trigger if the systemd timer hasn't been run in the previous 24hrs. Is there a better way or shall I just disable the service and live with the timer?

Not sure what dnf is doing on boot, any ideas?

Thanks, Jon

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-12-12 17:15:49 -0500

Update : I've disabled dnf.makecache.service as I can't see the rationale to have this run at boot when there is a timer to run 10 minutes after boot. So that give me back ~24 secs.

I'm tempted to disable the mlocate-updatedb.service as, again, there is a timer, though only to run once a day. I believe that systemd will run a timer is the defined time has been exceeded, is this correct? If this is correct then this service does seem unnecessary.

Cheers, Jon

edit flag offensive delete link more
0

answered 2015-12-13 03:36:18 -0500

PastorDi gravatar image

dnf-makecache need to check the system updates. (I turned it off) mlocate-updatedb need to search in the file system. Its a bug https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-12-10 15:00:10 -0500

Seen: 719 times

Last updated: Dec 13 '15