Ask Your Question
0

f23 applications menu has some empty sections after f22 upgrade

asked 2015-12-06 15:43:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

After upgrading from f22 to f23 I have a few blank slots in my applications menu. Accessories, internet, universal access, wine, and other are all blank when I hover my mouse over them, I'm not sure if anything is missing from the other menu sections but they seem fine.

Is there a way to repopulate the whole menu or would I have to add each item individually? I'm guessing the only way to fix this is from the command line and I don't know how to do that. When I open main menu it shows there should be items in these blank sections. I've tried clicking restore system configuration, I've also tried adding items that weren't previously selected, as well as trying to add back items that already were in the menu, none of these seem to have done anything to change the menus blank spots.

The menus sections that were populated I can edit just fine with main menu, adding, removing, and replacing items seems to work just fine. It's just the sections that are blank that I can't seem to do anything with.

edit retag flag offensive close merge delete

Comments

alacarte errors: /usr/lib/python2.7/site-packages/Alacarte/MainWindow.py:22: PyGIWarning: GMenu was imported without specifying a version first. Use gi.require_version('GMenu', '3.0') before import to ensure that the right version gets loaded. from gi.repository import Gtk, GdkPixbuf, Gdk, GMenu

(alacarte:20116): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(alacarte:20116): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

jbodhorn gravatar imagejbodhorn ( 2015-12-06 22:00:32 -0500 )edit

I've figured out how to add the items back but it is a painful process when done one by one... create new accessories menu create new item for each item that I want.... this involves having to figure out the location of the binary or command to run it and finding and assigning the proper icon... Seriously if I have to do it one by one it will take me a month... I'm about ready to switch back to ubuntu. Someone please help I really don't feel like wiping my laptop because of a screwed up menu and there is no way I am adding the items all back individually.

jbodhorn gravatar imagejbodhorn ( 2015-12-06 23:14:16 -0500 )edit

If it wasn't for the fact that all the old items are listed I wouldn't even be able to add back the items one at a time, I wouldn't be able to even remember what was there let alone know what to type in the boxes for adding to something to alacarte. I've tried reinstalling alacarte and I'm still getting the same errors when running from cli... all the apps that don't appear on my applications menu seem to be installed they just don't show up in the menu.

jbodhorn gravatar imagejbodhorn ( 2015-12-06 23:21:49 -0500 )edit

Do you use gnome's Application Menu extension? Do you have Applications in you top-left corner or Activities?

If it is an extension, could you try to remove it and install it again from https://extensions.gnome.org/extensio...

kukacek gravatar imagekukacek ( 2016-01-09 16:13:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-09 10:27:02 -0500

smola gravatar image

My Accessories map was also blank. After a few days I checked and unchecked some things in Alacarte inside Accessories. Clicked "Restore system settings" a few times. Reloaded the shell (Alt+F2+r). Nothing helped. Then today removed Krusader (which is a KDE app!), XFE and IceCat and Accessories reappeared!? Maybe inbetween I removed some more things. Can't remember, sorry.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-12-06 15:43:10 -0500

Seen: 285 times

Last updated: Jan 09 '16