No (analog) sound output w/ Realtek ALC269VC (Thinkpad X230)

asked 2015-12-01 12:43:47 -0500

florian gravatar image

updated 2015-12-04 14:55:58 -0500

I do have a Lenovo Thinkpad X230 that has a Realtek ALC269VC sound chip onboard, Fedora 22 installed. Unfortunately, the speakers don't output any sound (while headphone jack and sound over HDMI/MiniDP works fine).

I already ran dnf reinstall alsa-plugins-pulseaudio which didn't do the trick.

alsamixer does not show anything suspicious to me. No channel is muted, no auto-mute...

I recently switched hardware and restored my entire home-dir on my new machine (including ~/.config/pulse/ and ~/.config/gconf/system/pulseaudio). Could that be the problem? What about just deleting those two directories?

Output of rpm -qa | grep alsa:


Output of lspci -vvnn:

00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
    Subsystem: Lenovo Device [17aa:21fa]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 31
    Region 0: Memory at f2530000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

EDIT: In the meantime, I also added a model option to the kernel module by creating /etc/modprobe.d/sound.conf with the following content

options snd-hda-intel model=headset-mic vid=8086 pid=1e20

Didn't help.

EDIT2: Isn't it strange that alsactl init fails with the following output?

alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Intel PantherPoint HDMI" "HDA:10ec0269,17aa21fa,00100203 HDA:80862806,80860101,00100000" "0x17aa" "0x21fa"
Hardware is initialized using a generic method

Going to paste the output of ` here - plenty of information.

edit retag flag offensive close merge delete


You can delete any config file in home, a new config file will be generated. FWIW last time I had a similar problem it was due to my son re-wring the sound cables, so check the back of the card and make sure the speakers are plugged in properly.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-12-01 13:21:25 -0500 )edit

Hi, I deleted the config files but no success. (My son is still to young to re-wire anything ;-). I am on a laptop without external speakers...)

florian gravatar imageflorian ( 2015-12-01 14:35:47 -0500 )edit

Well, I kind of similar situation but now sound only works on Headphone. One thing do I have installeed alsa-firmaware and alsa-tools-firmware not sure if it helps

aeperezt gravatar imageaeperezt ( 2015-12-01 15:37:35 -0500 )edit

Hi @aeperezt: I installed the packages mentioned in your comment but unfortunately it doesn't solve the problem. What I figured out though is that my headphone jack works. Should we file a bug? Are you on the same hardware/chip?

florian gravatar imageflorian ( 2015-12-01 16:22:31 -0500 )edit

Have you opened pavucontrol or the gnome sound settings to ensure your desired output is selected and not muted?

randomuser gravatar imagerandomuser ( 2015-12-02 00:13:31 -0500 )edit