Ask Your Question
1

xen on fedora 23 boot issue

asked 2015-11-27 18:47:26 -0500

romain gravatar image

updated 2015-12-01 16:20:31 -0500

Hi, I having an issue to boot the Xen kernel on Fedora 23 and can't really know what's not working so I need your help until I open a ticket with fedora. Ok, here is the story. I have installed Fedora 23 and use the http://wiki.xen.org/wiki/Fedora_Host_... howto for the setuo, It was working very find until the last update (xen 4.5.2). Now, everytime the xen boot entry is selected, I got this:

Loading Xen 4.5.2
error: can't find command 'multiboot'.
Loading Linux 4.2.6-301.fc23.x86_64 ...
error: can't find command 'module'.
Loading Initial ramdisk ...
error: can't find command 'module'.

Other entries for fedora without xen are working fine. At least I can boot the system... Anybody have any clue why i'ts not working and what I can do to fix that?

Any help will be greatly appreciated... Thanks!

edit retag flag offensive close merge delete

Comments

It happened to me also, I would be glad to see a solution.

kaiiak gravatar imagekaiiak ( 2015-11-29 03:03:15 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-12-02 22:04:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Ok I found a fix:

  • First in the grub menu, when I tried to to insmod to install some modules to be able to boot, I got some message indicating that the none of the modules I tried to install was found.
  • So I search what rpm package provide the multiboot.mod module and the other ones. Found that the package grub2-efi-modules-2.02-0.24.fc23.x86_64 was not installed.
  • Once installed I found the files in /usr/lib/grub/x86_64-efi.
  • After another reboot, still no luck and tried this time again to install manually some modules and found a message saying that the modules could not be found in /EFI/fedora/x86_64-efi.
  • I reboot using the working fedora boot entry and there are no modules on folder in /boot/efi/EFI/fedora/.
  • I tried to create a symlink to /usr/lib/grub/x86_64-efi but for some reason it was not working (operation not permitted) So I simply copy the folder x86_64-efi to /boot/efi/EFI/fedora/. And this time I was able to boot Xen.

So I guess the package was not installed after the update (should it be a requirement?) and the path is either not correct or a symlink should be created and checked to be sure the modules are where grub is expecting them.

After that I got a little issue to start to VMs:

# xl create machine.xl 
Parsing config from machine.xl
libxl: error: libxl_create.c:1034:domcreate_launch_dm: unable to add disk devices
libxl: error: libxl_dm.c:1467:kill_device_model: unable to find device model pid in /local/domain/1/image/device-model-pid libxl: error: libxl.c:1425:libxl__destroy_domid: libxl__destroy_device_model failed for 1 
libxl: error: libxl_device.c:780:libxl__initiate_device_remove: unable to get my domid libxl: error: libxl.c:1461:devices_destroy_cb: libxl__devices_destroy failed for 1
 #

I followed the trick given here: http://www.gossamer-threads.com/lists...

# /usr/bin/xenstore-write "/local/domain/0/domid" 0

And all is working fine again :) For information the bug https://bugzilla.redhat.com/show_bug.... has been opened.

edit flag offensive delete link more
0

answered 2015-11-30 13:51:33 -0500

Fabash gravatar image

updated 2015-11-30 13:52:55 -0500

Hi Romain

The issues you observed are commands executed from /boot/grub2/grub.cfg

Both commands 'multiboot' and 'module' are part of grub module 'multiboot.mod'

# grep -E --color "multiboot|module" /boot/grub2/i386-pc/command.lst 
kfreebsd_module: bsd
kfreebsd_module_elf: bsd
knetbsd_module: bsd
knetbsd_module_elf: bsd
module2: multiboot2
module: multiboot
multiboot2: multiboot2
multiboot: multiboot

 # ls -als /boot/grub2/i386-pc/multiboot.mod
 12 -rw-r--r--. 1 root root 12172 16 août   2014 /boot/grub2/i386-pc/multiboot.mod

Could check if you have this file ?

For some reasons, it is not loaded at boot by grub. I've just tried to install the kernel by following the instructions on your link. I did'nt get the issues, the kernel is loaded and no errors. Going into a grub shell confirms that I have also this module.

Here is my proposal: maybe you could try to force loading it through your /boot/grub2/grub.cfg by adding the command 'insmod multiboot' in the corresponding entry

menuentry 'Fedora, with Xen hypervisor' --class fedora --class gnu-linux --class gnu --class os --class xen $menuentry_id_option 'xen-gnulinux-simple-9afdcdba-2dd1-4021-a888-7e6721058399' {
        insmod part_msdos
        insmod ext2
        insmod multiboot
        ....

Please, note that it's a temp workaround that will be deleted at next Kernel installation by dnf or any new grub2-mkconfig...untill you force it in /etc/grub.d/20_linux_xen

edit flag offensive delete link more

Comments

Hi and thanks for your comments and troubleshooting tips, it's very appreciated :) I will test what you suggest. I forgot to mention 2 things: - I work with an EFI boot , EFI, BOOT and LVM that contain the ROOT partion are all part of the software RAID1

romain gravatar imageromain ( 2015-12-01 10:41:00 -0500 )edit

You're welcome ! Hope my instructions could help you. But I don't know much about specific parts regarding EFI boot.

Fabash gravatar imageFabash ( 2015-12-01 14:32:55 -0500 )edit

I am having the same issue and am also booting EFI from a raid 1 configuration. There is no "/boot/grub.cfg" file or "/boot/grub2/i386-pc/" directory. copying the modules also worked for me, but I have not tried creating any VMs yet.

jackgable gravatar imagejackgable ( 2015-12-13 23:43:28 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-11-27 18:47:26 -0500

Seen: 3,766 times

Last updated: Dec 01 '15