Ask Your Question
1

Problems with internet connetivity

asked 2012-10-11 02:50:56 -0500

Harsh gravatar image

updated 2012-10-15 09:21:31 -0500

I am new to Linux!
I am from India using BSNL Broadband. I have a working (top dwld speed=.91Mbps) internet connection which very well on Windows 7 but sometimes(quite a common problem) Fedora shows that i am connected but i just can't surf. Firefox,opera,chrome STRUGGLE to load pages....and after sometime it stops loading..Sometimes my DSL connection works quite well on Fedora.I also see my ip address and other detailsimage description. I took a screenshot of my desktop but i can't upload it through windows...I don't know why windows can't read it.I will try to upload it later.please tell me what should i do. I use >Realtek RTL8101E Family PCI-E Fast Ethernet NIC (NDIS 6.20) on windows 7 my modem is image description Another screen

edit retag flag offensive close merge delete

Comments

check if mtu is set to 1500 if not set it with "ifconfig eth0 mtu 1500"

Akshay gravatar imageAkshay ( 2012-10-11 08:27:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-11 04:49:03 -0500

PKS gravatar image

updated 2012-10-11 08:26:09 -0500

Akshay gravatar image

Way 1:

type this command

su -c "pppoe -setup"

Enter your

root

password and setup your pppoe connection by using your login credential provided by BSNL.

Way2:

Configure the modem to automatically connect when system boots up. Connect the modem and type http://192.168.1.1

A window for login will appear type user name:admin and password:admin and set settings there.

Settings may differ depending upon which company's modem you are using.

edit flag offensive delete link more

Comments

Way 1 will only work if the connection is, in fact, pppoe. Do you have a reason to think that's the case, as it's very rare.

sideburns gravatar imagesideburns ( 2012-10-13 15:37:02 -0500 )edit

well no ISP in India provides help to Linux users, check if DHCP client is working, check your ip address it should be like 192.168.1.1/255, i would have sent you my settings but i am using ZTE

Akshay gravatar imageAkshay ( 2012-10-15 08:08:09 -0500 )edit

Next time you're having this issue, open a terminal and run this command: ifconfig, and look at your inet address; it should be 192.168.1.X. If it is, run this: ping 18.7.22.69 which will ping www.mit.edu without needing DNS. (I know that server responds to pings, which is why I suggest it.) Let us know what happens.

sideburns gravatar imagesideburns ( 2012-10-15 16:29:07 -0500 )edit

change your DNS to 192.168.1.1 here the snapshot https://dl.dropbox.com/u/95286161/Screenshot%20from%202012-11-14%2021%3A24%3A27.png, if you want to change the DNS change it in router

Akshay gravatar imageAkshay ( 2012-11-14 09:57:38 -0500 )edit

@Harsh please confirm your router ip is it 192.168.1.1 or its 192.168.1.12

Akshay gravatar imageAkshay ( 2012-11-14 10:00:01 -0500 )edit

Question Tools

Stats

Asked: 2012-10-11 02:50:56 -0500

Seen: 1,754 times

Last updated: Oct 15 '12