Ask Your Question

hi i m using Cent OS getting this error plz help

asked 2015-11-25 08:17:03 -0600

ibrahim1052 gravatar image

updated 2015-11-26 04:44:11 -0600

cobra gravatar image
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base:
 * epel:
 * extras:
 * nux-dextop:
 * updates: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror. [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: nux-dextop. Please verify its path and try again
edit retag flag offensive close merge delete


Hi: What CentOS version are you using? Could you confirm that you have access to the EPEL repositories configured in your yum setup? How did you installed epel? Have you tried doing a yum clean all;yum update ? AFACT there's no updates on that server, only x86_64

casep gravatar imagecasep ( 2015-11-25 12:07:10 -0600 )edit

You do understand, I hope, that this is a support forum for Fedora, not CentOS. You may be better off asking at a CentOS forum.

sideburns gravatar imagesideburns ( 2015-11-25 14:17:31 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-11-26 04:48:01 -0600

cobra gravatar image

You are using a repository that has problems connecting to its main sites or to its mirrors. This might be a temporary issue, repositories (especially those with few mirrors) can suffer this from time to tome.

I'm not sure what the nux-dextop repository is, but it seems to be the culprit in this case. Try disabling it either through its yum configuration file or on the command line and re-run the update.

edit flag offensive delete link more


The nux-desktop repository is some kind of replacement for rpmfusion. Its usage is quite common for RHEL/CentOS 7 users since rpmfusion does not offer packages for RHEL/CentOS 7 (yet).

Axel Sommerfeldt gravatar imageAxel Sommerfeldt ( 2015-12-03 15:53:54 -0600 )edit

answered 2015-12-03 15:51:32 -0600

Axel Sommerfeldt gravatar image

You are running the 32-bit variant of CentOS 7 and have the nux-desktop repository enabled. But the nux-desktop repository is only available for the 64-bit variant of RHEL/CentOS 7. So either install the 64-bit variant of CentOS 7 instead, or disable the nux-desktop repository.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-11-25 08:17:03 -0600

Seen: 403 times

Last updated: Nov 26 '15