Ask Your Question

'nvidia-xconfig' breaks X.

asked 2012-10-06 22:33:22 -0500

LETTIER gravatar image

updated 2012-10-07 19:41:41 -0500

mattdm gravatar image
  • Fedora 17
  • Lenovo Z580
  • Kernel 3.5.4-1 or 3.5.3-1

I recently updated the kernel and since then my nvidia chip and Bumblebee do not run.

I followed this guide again to reinstall Bumblebee.

However, optirun gives

[ERROR] The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

When I go to the NVIDIA X Server Settings I get

You do not appear to be using NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

However, upon doing that, the system hangs at [OK] Started display manager. and using startx gives

ERROR: could not insert 'nvidia':No such file or directory

Fatal server error: no screens found

Xorg.0.log states:

(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver   
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your system's kernel log for additional error messages.  
(II) UnloadModule:    "nvidia"     
(II) Unloading nvidia     
(EE) Failed to load module "nvidia" (module-specific error, 0)  
(EE) No drivers available.

messages reads:

bumblebeed[2511]: [ERROR] Module 'nvidia' is not found.

Only upon deleting xorg.conf do I get the GUI login again but no 3D programs run complaining about missing GLX.


edit retag flag offensive close merge delete



Rather than marking your question as "solved" in the title, you should be able to mark your own answer as accepted, which is the site's way of indicating "solved". Let me know if that doesn't work.

mattdm gravatar imagemattdm ( 2012-10-07 19:40:43 -0500 )edit

@davidva — we need to build up the community here, that's all.

mattdm gravatar imagemattdm ( 2012-10-08 06:38:33 -0500 )edit

@LETTIER Can you try now? I lowered the threshold required for that (because it seems counterproductive and just encourages work-arounds). Plus, you've got the karma now.

mattdm gravatar imagemattdm ( 2012-10-08 11:23:38 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2012-10-07 18:39:21 -0500

LETTIER gravatar image

updated 2012-10-07 18:40:40 -0500

To get Nouveau back I ran through this guide:

Then to get CUDA back I followed this guide: but removed xorg.conf and anything that blacklisted nouveau (still keeping the nvidia libs though).

Then I ran through this guide to get optimus back: but had to tweak it for the newer Bumblebee by renaming the downloads bbswitch-0.4.2 and bumblebee-3.0. Changing step four to read

tar xvzf bbswitch-0.4.2.tar.gz
sudo cp -Rv  bbswitch-0.4.2 /usr/src
sudo ln -s /usr/src/bbswitch-0.4.2/dkms/dkms.conf /usr/src/bbswitch-0.4.2/dkms.conf
sudo dkms add -m bbswitch -v 0.4.2
sudo dkms build -m bbswitch -v 0.4.2
sudo dkms install -m bbswitch -v 0.4.2

Changing step six to read:

tar xvzf bumblebee-3.0.tar.gz
cd bumblebee-3.0
autoreconf -fi
./configure --prefix=/usr --sysconfdir=/etc 
sudo make install 
sudo cp scripts/systemd/bumblebeed.service /lib/systemd/system

Now optimus + cuda works like before.

edit flag offensive delete link more

answered 2012-10-07 00:29:26 -0500

sideburns gravatar image

You don't specify, but I'm guessing that you're using the binary blob from nVidia. If so, you need to boot to a CLI (X not running) and re-install it, every single time there's a kernel update. If so, go here to get instructions on how to install a much saner version of the driver that gets updated properly along with the kernel so that you don't have to worry about it anymore.

edit flag offensive delete link more


I know that I put the link in. Let's try again:

sideburns gravatar imagesideburns ( 2012-10-07 15:08:47 -0500 )edit

Question Tools

1 follower


Asked: 2012-10-06 22:33:22 -0500

Seen: 4,429 times

Last updated: Oct 07 '12