Ask Your Question
0

Skype not starting anymore in F23

asked 2015-11-15 05:12:11 -0500

Vincenzo Pii gravatar image

Hello,

I upgraded to Fedora 23 and at the moment I cannot start skype anymore on my system.

If I try to run it from the command line, this is the error that I get:

$  skype
skype: error while loading shared libraries: /lib/libdbus-1.so.3: file too short

If I try to reinstall dbus, I have a series of errors like the following:

file /usr/share/man/man1/dbus-uuidgen.1.gz from install of dbus-1:1.10.2-1.fc23.x86_64 conflicts with file from package dbus-1:1.10.0-1.fc23.x86_64
edit retag flag offensive close merge delete

Comments

Please update your system first, and then put the full command and output.

skytux gravatar imageskytux ( 2015-11-15 14:09:36 -0500 )edit

@skytux My system is up-to-date (sudo dnf upgrade has nothing to do)

Vincenzo Pii gravatar imageVincenzo Pii ( 2015-11-15 14:50:03 -0500 )edit

@skytux, and here is the full output: http://pastebin.com/mAtSQn6z

Vincenzo Pii gravatar imageVincenzo Pii ( 2015-11-15 14:51:39 -0500 )edit

You should try sudo dnf reinstall dbus.

skytux gravatar imageskytux ( 2015-11-15 15:20:34 -0500 )edit

@skytux, tried, but not luck, I still have the same error

Vincenzo Pii gravatar imageVincenzo Pii ( 2015-11-18 14:16:32 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2015-11-19 13:04:50 -0500

Vincenzo Pii gravatar image

updated 2015-11-19 13:05:43 -0500

Issue fixed.

It was probably due to a crash that I had during a dnf upgrade.

This is what I did.

Run

sudo ldconfig

This was showing a whole lot of problems, like:

/sbin/ldconfig: File /lib/libgstcheck-1.0.so.0.601.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstcontroller-1.0.so.0.601.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstcheck-1.0.so.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstbase-1.0.so.0.601.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstreamer-1.0.so.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstnet-1.0.so.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstcontroller-1.0.so.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstreamer-1.0.so.0.601.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstbase-1.0.so.0 is empty, not checked.
/sbin/ldconfig: File /lib/libgstnet-1.0.so.0.601.0 is empty, not checked.

All those libraries were 0 bytes in size.

For each one of them (actually each step fixed many of them), I did the following (let's consider libgstnet-1.0.so.0.601.0 as example).

  1. Check what package provides the library (not the asterisk *)

    sudo dnf provides */lib/libgstnet-1.0.so.0.601.0
    
  2. Reinstall the package

    sudo dnf reinstall <package_name>
    

For some packages, I had to uninstall the previous version to avoid conflicts (sudo dnf remove <prev_version>)

edit flag offensive delete link more
0

answered 2015-11-19 18:44:36 -0500

sergiomb gravatar image

lpf-skype from rpmfusion rocks !

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-11-15 05:12:11 -0500

Seen: 366 times

Last updated: Nov 19 '15