Ask Your Question
0

Clients cannot access Samba Shares

asked 2012-06-05 10:51:06 -0500

jlego gravatar image

I had turned an old computer into a file/print sharing and web server with Fedora 16. I had Samba and LAMP stack all working. However, I decided to get hardware specifically for use as this server (the old one was a bit overpowered for it.)

Now I cannot get Samba working for anything. Same Fedora version (16) I used the Samba Configuration GUI tool to setup the users and shares. What happened was both clients (Windows 7 and Mac OSX) can connect to the server and see the shares, but cannot access those shares. Both give an error relating to something being wrong with the network path. I've tried connecting using the server's IP and get the same errors.

The usernames are the same as on the windows & mac.

I've copied the smb.conf from the old computer (the one where Samba was working) to the new one with no change (obviously matching the new share definitions.)

The drive I'm trying to share is 3TB (formatted ext3 with gparted). Could that cause issue?

I'm very frustrated with this right now as everything I've read tells me there should be no problems. Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

There is an great tutorial for setting up Samba on Fedora already answered here: https://ask.fedoraproject.org/en/question/40353/how-to-enable-samba-share-for-a-specific-directory-fedora-20/

This answer gives indept explanation on how to create share, setup firewall to let users connect to your samba server and how to disable selinux from blocking samba. Good luck.

valentt gravatar imagevalentt ( 2014-05-31 16:33:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-27 15:34:01 -0500

kerneltrap66 gravatar image

most likely it is selinux policy. any directory or mnt point you are wanting network access to is best to be named public.. for example, my 2nd harddrive is sdb, its 1 large ext4 partition, i did "mkdir public" u could do this where ever, then i edited /etc/fstab to have this.. /dev/sdb1 /public ext4 ....what ever options u need. now once i share it se leaves it alone

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-06-05 10:51:06 -0500

Seen: 1,738 times

Last updated: Sep 27 '12