Ask Your Question
0

Upgrade from Fedora-21

asked 2015-11-09 23:09:34 -0500

Mohan G gravatar image

updated 2015-11-10 22:29:10 -0500

mether gravatar image

I am using Fedora-21 workstation and want to upgrade to latest version of fedora, but I am having issues.

I tried

$ sudo dnf update --refresh # worked successfully
$ sudo dnf install dnf-plugin-system-upgrade # worked successfully
$ sudo dnf system-upgrade download --releasever=22  # gave errors

But I am getting following errors,

Error: package perl-PlRPC-0.2020-15.fc20.noarch requires perl(:MODULE_COMPAT_5.18.0), but none of the providers can be installed

I also tried,

sudo dnf system-upgrade download --releasever=23 # gave errors

Then I tried,

$ sudo dnf distro-sync # worked successfully
$ sudo dnf system-upgrade download --releasever=23 # gave errors

But I am getting same error. How should I proceed.

edit retag flag offensive close merge delete

Comments

1

Try running dnf provides perl-P1RPC to find out what package you need. It's possible that you got it from a non-Fedora source.

sideburns gravatar imagesideburns ( 2015-11-10 02:47:11 -0500 )edit

It may be enough to just remove it, then re-install after the upgrade is complete. Keep a list of any apps that are removed with it, so you can add them all back.

cobra gravatar imagecobra ( 2015-11-10 05:00:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-11-10 11:59:36 -0500

Try running sudo dnf system-upgrade download --releasever=23 --allowerasing

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-11-09 23:09:34 -0500

Seen: 885 times

Last updated: Nov 10 '15