Ask Your Question
0

Lightdm greeter has wrong keyboard layout

asked 2015-11-06 05:48:29 -0500

mithrial gravatar image

I run Fedora 23 as of today, but the following problem was already present in Fedora 22.

I use Cinnamon as window manager and lightdm-gtk-greeter as login screen. Throughout my system I configured de_DE.utf8 as keyboard layout. In Cinnamon it is working, on every TTY it is working but on the login screen it is English (or American, I don't know which it is actually). This is really annoying because I have characters in my password that are located elsewhere on my German layout.

In the lightdm config, I can put a widget on the login screen to change the layout, but it is already set to de_DE.utf8 with no change in behavior, Z is still Y.

Can someone point me to the right direction where to configure the keyboard layout?

edit retag flag offensive close merge delete

Comments

Hint: de_DE.utf8 is not the keyboard layout, but the text encoding, filename encoding etc.

erik gravatar imageerik ( 2018-01-27 16:06:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-01-27 16:03:52 -0500

erik gravatar image

localectl will do this. The man page will give you the syntax, but here are some examples.

  • list keymaps: localectl list-keymaps
  • change console keymap: localectl set-keymap jp106
  • change x11 keymap: localectl set-x11-keymap jp

The set-x11-keymap options are much more flexible, see the manpage for instructions on listing the available parameters.

(Source: https://ask.fedoraproject.org/en/ques... )

edit flag offensive delete link more

Comments

The localectl set-x11-keymap de is the command to set the keboard mapping for the lightdm greeter.

villykruse gravatar imagevillykruse ( 2018-01-28 11:38:02 -0500 )edit

Didn't work for me, localectl reports console keymap being dvorak and X11 model and variant pl dvorak. Greeter lightdm-deepin-greeter however shows the keyboards from the Deepin environment -- "PL" and "PL Dvorak". Nevertheless even when "PL Dvorak" is chosen by default or explicitly, the keyboard is still QWERTY and even when locking the screen, not only on login. Also locking the screen breaks the layout and sets it to QWERTY until changed twice.

dhill gravatar imagedhill ( 2018-05-28 10:24:03 -0500 )edit
0

answered 2015-11-06 06:57:32 -0500

geforce gravatar image

Try using mintlocale to set system-wide locale

edit flag offensive delete link more

Comments

Sadly, this didn't help.

mithrial gravatar imagemithrial ( 2015-11-07 05:43:30 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-11-06 05:48:29 -0500

Seen: 2,142 times

Last updated: Jan 27 '18