Ask Your Question
0

desktop resolution gets messed up while playing games

asked 2015-11-01 03:27:34 -0500

updated 2015-11-03 18:58:25 -0500

mether gravatar image

Hi,

My PC Configuration is:

CPU: Intel 4 3.0 GHz RAM: 4gb Graphics: Onboard HDD: 160gb primary, 500gb secondary sata hard disks Motherboard: MSI G41

Recently i have started having a weird problem, when i play games made for linux, my screen resolution gets messed up. My native resolution is 1024x768, but when the problem happens i have to change to 800x600 to see the full screen, plus the graphics quality also decreases. I am not a technical person, so can you please suggest a permanent solution that i can apply immediately as i don't want to either limit my gaming experience or stick to shitty resolution.

After running the lspci | grep VGA command i got the following output:

Output:

[gaurav@localhost ~]$ lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) [gaurav@localhost ~]$

Regards,

edit retag flag offensive close merge delete

Comments

1

Welcome to ask.fedora. Please run the command lspci | grrep VGA in a terminal, and edit your question to include the output. The answer may depend on just what graphics hardware you have.

sideburns gravatar imagesideburns ( 2015-11-01 22:11:22 -0500 )edit

OK, you have Intel graphics, so you don't need any special drivers. Since you didn't say otherwise, I'll presume that you're using Gnome, which I don't know. With luck, somebody who does use it will be able to suggest something.

sideburns gravatar imagesideburns ( 2015-11-02 02:11:09 -0500 )edit

hi sideburns, yes im using gnome, thanks for your response. I did a little research on the net, tried doing a few things with xrandr, apparently this problem happens when you are playing an old game or a game that has an interface of an old game. hopefully someone out there must have a solution for this.

gaurav.a.vaidya gravatar imagegaurav.a.vaidya ( 2015-11-02 05:03:11 -0500 )edit

What game ? using wine ? If so, it is likely to be considered a bug in the game. Run the game in an emultaed desktop or reset the resolution after wine exits with xrandr or similar. You cna try filing a bug report with wine.

bodhi.zazen gravatar imagebodhi.zazen ( 2015-11-03 13:16:54 -0500 )edit

Hey guys,

It was a monitor issue, the problem has been solved. Nothing wrong with fedora

gaurav.a.vaidya gravatar imagegaurav.a.vaidya ( 2015-11-04 08:34:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-03 11:00:04 -0500

it probably is a monitor issue, im getting a new one soon and will post an update, hopefully that will solve the problem. apparently the issue arose because i shifted from an 18 inch monitor to a 15 inch monitor.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-11-01 03:27:34 -0500

Seen: 320 times

Last updated: Nov 03 '15