Ask Your Question
0

Right-to-left in Terminal

asked 2015-10-29 05:54:12 -0500

evb0110 gravatar image

I'm considering switching to Fedora, so I've tried it in a virtual machine. The problem is that Terminal doesn't support RTL (right-to-left) language input, so the letters appear from left to right and without ligatures, as if they were English)

In my case the input goes from Syriac keyboard layout. Syriac keyboard is included in Fedora but, as it turns out, it is not fully supported in Terminal.

Are there any ways to solve the problem?

edit retag flag offensive close merge delete

Comments

Correct me if am wrong, your keyboard supports Syriac alphabets and you want the alphabets to appear from right to left as you type?

anishjp gravatar imageanishjp ( 2015-10-29 14:58:57 -0500 )edit

Yes, that is exactly what I want. Now I can't e.g. use grep and other terminal commands with a right-to-left argument.

There is support for two Syriac keyboard layouts in Fedora (though the fonts are ugly and don't work properly), but in Terminal it doesn't work at all.

evb0110 gravatar imageevb0110 ( 2015-10-30 02:36:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-29 17:43:59 -0500

Rabin gravatar image

For RTL support in the terminal you will need to use a terminal which support Bidi, for example Konsole which is part of KDE , or mlterm.

edit flag offensive delete link more

Comments

Thanks for info!

evb0110 gravatar imageevb0110 ( 2015-10-30 02:36:09 -0500 )edit

It turned out that mlterm not only doesn't support Syriac but in fact collapses as soon as I try to input a Syriac letter.

evb0110 gravatar imageevb0110 ( 2015-10-30 13:25:54 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-10-29 05:54:12 -0500

Seen: 191 times

Last updated: Oct 29 '15