Ask Your Question
0

Doesn't hibernate when I close the lid

asked 2015-10-22 09:18:02 -0500

Lord_Vader gravatar image

I have edited the file /etc/systemd/logind.conf and change the line

#HandleLidSwitch=suspend

to

HandleLidSwitch=hibernate

After that I restarted system-login service (by executing the command systemctl restart systemd-logind.service) AND rebooting the system. I have checked that the changes is correct. I'm using a Lenovo Thinkpad T430.

The problem is that the computer still suspend when I close the lid, not going into hibernation.

edit retag flag offensive close merge delete

Comments

Have you tested on console ?, or in some window manager ? , windows manager (gnome or kde) also can set lid switch

sergiomb gravatar imagesergiomb ( 2015-10-22 13:19:55 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-10-22 14:03:37 -0500

Lord_Vader gravatar image

I should have tested the obvious option first. I didn't do it because it hasn't worked on Ubuntu for several years.

I only needed to set the When laptop lid is closed option to hibernate in Xfce's power manager. Works without problems.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-10-22 09:17:12 -0500

Seen: 289 times

Last updated: Oct 22 '15