Ask Your Question
0

Wifi connection issue

asked 2015-10-21 10:36:13 -0500

michaelmwangi gravatar image

Hi all I recently got a Lenovo S41 and installed Fedora 22. Everything works perfectly except for wifi. I can see the wifi SSID but it doesnot connect. According to this here's the output of journalctl -f -u NetworkManager

Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: starting connection 'MY WIFI'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 1 of 5 (Device Prepare) scheduled...
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 1 of 5 (Device Prepare) started...
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 2 of 5 (Device Configure) scheduled...
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 1 of 5 (Device Prepare) complete.
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 2 of 5 (Device Configure) starting...
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): device state change: prepare -> config (reason 'none') [40 50 0]
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: (wifi) connection 'MY WIFI' has security, and secrets exist.  No new secrets needed.
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: added 'ssid' value 'MY WIFI'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: added 'scan_ssid' value '1'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: added 'key_mgmt' value 'WPA-PSK'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: added 'psk' value '<omitted>'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: added 'proto' value 'WPA RSN'
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  (wlp2s0): Activation: Stage 2 of 5 (Device Configure) complete.
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <warn>  Couldn't disconnect supplicant interface: This interface is not connected.
Oct 21 11:19:00 michael.theshire NetworkManager[913]: <info>  Config: set interface ap_scan to 1
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <warn>  (wlp2s0): Activation: (wifi) association took too long, failing activation
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <info>  (wlp2s0): device state change: config -> failed (reason 'ssid-not-found') [50 120 53]
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <warn>  (wlp2s0): Activation: failed for connection 'MY WIFI'
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <info>  (wlp2s0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <info>  (wlp2s0): deactivating device (reason 'none') [0]
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <info>  (wlp2s0): supplicant interface state: scanning -> disconnected
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <warn>  Couldn't disconnect supplicant interface: This interface is not connected.
Oct 21 11:19:25 michael.theshire NetworkManager[913]: <info>  (wlp2s0): supplicant interface state: disconnected -> scanning
Oct 21 11:19 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-16 17:46:04 -0500

lovepump gravatar image

updated 2016-12-16 19:21:02 -0500

My suspicion is the space in your ESSID "MY WIFI" is getting in the way and you might need to quote it in configuration files. Additionally, I haven't had a good experience with generating a pre-shared key with wpa_passphrase when the ESSID has a space in it; quoting it seems to make a key that "expects" the ESSID to have quotes around it, and wpa_pasphrase takes parameters separated by a space.

The first thing I would look at is changing the ESSID so that it has no spaces on your wireless access point. Take it out of the equation. Obviously, this might require a change to the naming used in your /etc/wpa_supplicant/wpa_supplicant.conf file for the ESSID, and possibly also NetworkManager as well.

If that doesn't clear it up we will want to see the contents of /etc/wpa_supplicant/wpa_supplicant.conf, and perhaps some of the other systemd networking configuration files

edit flag offensive delete link more

Comments

I just now noticed the answer is taking underscores and interpreting them as beginning and end for "italics", I'll edit it and make it code

lovepump gravatar imagelovepump ( 2016-12-16 19:19:23 -0500 )edit

Question Tools

Stats

Asked: 2015-10-21 10:36:13 -0500

Seen: 772 times

Last updated: Dec 16 '16