Ask Your Question
0

livecd-creator using the wrong Fedora version

asked 2015-10-19 12:13:59 -0500

afyr gravatar image

updated 2015-10-20 11:03:56 -0500

I'm trying to create a Fedora 22 livecd, but livecd-creator is creating a Fedora 24 livecd. Here is the repo statement in my kickstart file:

repo --name=fedora --mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=$basearch

I tried passing the releasever option to livecd-creator on the command line:

 livecd-creator --config=workspace/tt_000000_l_tester_f22_os/kickstart.virgin.mate/fedora-live-mate_compiz.ks --fslabel=virgin.mate --releasever=22 -v -d

The full text output is here. What am I doing wrong?

edit retag flag offensive close merge delete

Comments

IMO far better to download an updated ios - http://alt.fedoraproject.org/pub/alt/...

bodhi.zazen gravatar imagebodhi.zazen ( 2015-10-19 13:56:39 -0500 )edit

Can you provide the command and the corresponding output (at least the 50 initial lines of the output if it is longer than that) using fpaste or similar services?

hedayat gravatar imagehedayat ( 2015-10-19 14:19:33 -0500 )edit

hedayat, thanks for your help! I provided the command and uploaded the output.

afyr gravatar imageafyr ( 2015-10-19 15:51:53 -0500 )edit

You're welcome! Is this the complete output? I feel that there should be more line at the top. If not, check if it had created any log files with more detailed output.

also, make sure that there are no other repo= lines in your .ks file.

hedayat gravatar imagehedayat ( 2015-10-20 04:22:28 -0500 )edit

Yes, it is the complete output. There are no other repo= lines. This link https://paste.fedoraproject.org/28154... includes -v -d options for more verbose messages,

afyr gravatar imageafyr ( 2015-10-20 10:53:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-20 11:26:27 -0500

afyr gravatar image

Replacing:

%include fedora-repo.ks

in fedora-live-base.ks with:

repo --name=fedora --mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=$basearch

and removing fedora-repo.ks and fedora-repo-not-rawhide.ks resolved the issue.

edit flag offensive delete link more

Comments

:) So, there were other repo lines!

hedayat gravatar imagehedayat ( 2015-10-21 02:39:21 -0500 )edit

No there weren't. Only the lines that said to include those other files. All I did was move the repo line above from fedora-repo-not-rawhide.ks to fedora-live-base.ks

afyr gravatar imageafyr ( 2015-10-26 11:14:12 -0500 )edit

There were, but not in your .ks file but in the included ones!

hedayat gravatar imagehedayat ( 2015-10-26 14:07:39 -0500 )edit

Question Tools

Stats

Asked: 2015-10-19 12:13:59 -0500

Seen: 114 times

Last updated: Oct 20 '15