Ask Your Question

Post fc20 to fc22, have a problem with yum/dnf database ...

asked 2015-10-18 17:59:20 -0500

nyceyes gravatar image

Hello friends:

I just finished successfully upgrading from Fedora-20 to Fedora-22. There are, of course, some post-install cleanup things that I now need to perform. For example, removing some remaining fc20 packages, including old kernel packages, etc.

My problem is that there is some inconsistency in the rpm and/or dnf databases that I don't know how to fix in order to get sudo dnf update ..., sudo dnf remove ... and other modification-based dnf commands to successfully complete.

More specifically, the problem is the below complaint from dnf about kmod-wl-4.1.6, yet I'm running kernel-4.2.3. Even if kmod-wl-4.2.3 existed in the updates repository (it doesn't because sudo dnf search kmod-wl shows 4.1.6 as the latest version), I probably wouldn't be able to upgrade to it because the error below is preventing me from doing any kind of modification command before fixing that first. So, for example, if I wanted to install a totally unrelated package via sudo dnf -y install someUnrelatedPackage it won't let me. It's kind of like a catch-22.

kernel-uname-r = 4.1.6-200.fc22.x86_64 is needed by (installed) kmod-wl-4.1.6-200.fc22.x86_64-

So I have to fix this complaint manually first. I already tried the things below with no success.

Any ideas/suggestions on how to fix this? See the following. And thanks in advance! :)

Problem details:

jdoe@lenovo$ uname -r

jdoe@lenovo$ sudo rpm --rebuilddb
jdoe@lenovo$ sudo dnf clean all
jdoe@lenovo$ sudo dnf -y update

Last metadata expiration check performed 0:35:32 ago on Sun Oct 18 17:45:49 2015.
Dependencies resolved.
 Package                           Arch      Version                   Repository  Size
 insync                            x86_64          inSync      63 M
 kernel                            x86_64    3.19.3-100.fc20           @System    145 M
 kernel-modules-extra              x86_64    3.19.3-100.fc20           @System    8.4 M
 kmod-wl-3.19.3-100.fc20.x86_64    x86_64     @System    7.2 M

Transaction Summary
Upgrade  1 Package
Remove   3 Packages

Total size: 63 M
Downloading Packages:                    
Running transaction check

Error: transaction check vs depsolve:
kernel-uname-r = 4.1.6-200.fc22.x86_64 is needed by (installed) kmod-wl-4.1.6-200.fc22.x86_64-

To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

jdoe@lenovo$ rpm -qa | grep kmod-wl-
edit retag flag offensive close merge delete


sudo dnf remove kmod-wl-4.1.6-200.fc22.x86_64?

skytux gravatar imageskytux ( 2015-10-18 19:00:25 -0500 )edit

Thanks @skytux. Sadly no modification-based dnf (or yum and related utility) commands succeed. But I have a solution below.

nyceyes gravatar imagenyceyes ( 2015-10-18 19:51:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-10-18 19:54:15 -0500

nyceyes gravatar image

updated 2015-10-18 19:55:05 -0500

By brute-forcing the matter with the following command (a package that I didn't need), I was able remove the conflict.

sudo rpm -e kmod-wl-4.1.6-200.fc22.x86_64- --force

Everything worked after that. :)

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-10-18 17:59:20 -0500

Seen: 548 times

Last updated: Oct 18 '15